Support » Plugin: MailerLite - WooCommerce integration » Critical Error with version 1.6.9

  • This plugin causes issues with logged-in users and throws a critical error when removing an item from the cart using the floating widget.

    It also prevents logged-in users from adding items to cart, and prevents the removal of items on cart page.

    The problem has been isolated to this plugin specifically. Reverting back to 1.6.8 fixes the problem.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter stylise

    (@stylise)

    2022-06-16T17:00:09+00:00 CRITICAL Uncaught Error: Call to a member function syncProduct() on null in /.../.../.../wp-content/plugins/woo-mailerlite/includes/shared/api/class.woo-mailerlite-platform-api.php:467
    Stack trace:
    #0 /.../.../.../wp-content/plugins/woo-mailerlite/includes/shared/mailerlite-wp-functions.php(841): PlatformAPI->syncProduct('63', 7753, '...', 4.29, false, 'https://...', 'https://...', Array)
    #1 /.../.../.../wp-content/plugins/woo-mailerlite/includes/hooks.php(125): mailerlite_wp_sync_product(7753)
    #2 /.../.../.../wp-includes/class-wp-hook.php(309): woo_ml_product_update(7753)
    #3 /.../.../.../wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array)
    #4 /.../.../.../wp-includes/plugin.php(476): WP_Hook->do_action(Array)
    #5 /.../.../.../wp-content/plugins/woocommerce/includes/data-stores/class-wc-product-data-store-cpt.php(275): do_action('woocommerce_upd...', 7753, Object(WC_Product_Simple))
    #6 /.../... in /.../.../.../wp-content/plugins/woo-mailerlite/includes/shared/api/class.woo-mailerlite-platform-api.php on line 467
    • This reply was modified 3 months, 1 week ago by stylise.

    Hi,

    Did you try 1.6.10 ?
    For me, it resolved a similar critical error.

    Best regards

    Thread Starter stylise

    (@stylise)

    @joy0114 Not yet, but thanks for the comment.

    It would be cool if support acknowledged these issues that folks are helping them to address. But I guess it’s not like we pay them to use their software. Oh wait..

    thomas1018

    (@thomas1018)

    MailerLite – WooCommerce integration 1.6.6 update to 1.6.10 critical error.

    Warning: Invalid argument supplied for foreach() in /home/customer/www/domain.name/public_html/wp-content/plugins/woo-mailerlite/includes/shared/api/class.woo-mailerlite-rewrite-api.php on line 83

    Warning: Cannot modify header information – headers already sent by (output started at /home/customer/www/domain.name/public_html/wp-content/plugins/woo-mailerlite/includes/shared/api/class.woo-mailerlite-rewrite-api.php:83) in /home/customer/www/domain.name/public_html/wp-includes/pluggable.php on line 1421

    Thread Starter stylise

    (@stylise)

    Just a quick follow-up, version 1.6.10 fixed the issue for me.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.