Support » Plugin: StoreCustomizer - A plugin to Customize all WooCommerce Pages » Critical Error with StoreCustomizer 2.3.7 & Woocommerce 6.2.1

  • Resolved ttoaster

    (@ttoaster)


    Hi,

    The latest StoreCustomizer is not compatible with woocommerce 6.2.1 (it’s fine with 6.2), when 6.2.1 is installed a Critical Error warning is shown and the site fails to load (front and backend). After looking at the error log it seems that the issue is with StoreCustomizer, see extract below:

    [Wed Feb 23 13:12:20.436295 2022] [php7:error] [pid 26924] [client 51.148.173.39:45238] PHP Fatal error: Uncaught Error: Call to undefined function is_product() in /var/www/site/wp-content/plugins/woocustomizer-pro/includes/customizer/styles.php:1142\nStack trace:\n#0 /var/www/site/wp-includes/class-wp-hook.php(307): woocustomizer_customizer_library_build_styles()\n#1 /var/www/site/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()\n#2 /var/www/site/wp-includes/plugin.php(474): WP_Hook->do_action()\n#3 /var/www/site/wp-content/plugins/woocustomizer-pro/includes/customizer/styles.php(2973): do_action()\n#4 /var/www/site/wp-includes/class-wp-hook.php(307): woocustomizer_customizer_library_styles()\n#5 /var/www/site/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters()\n#6 /var/www/site/wp-includes/plugin.php(474): WP_Hook->do_action()\n#7 /var/www/site/wp-includes/script-loader.php(2105): do_action()\n#8 /var/www/site/wp-includes/class-wp-hook.php(307): wp_enqueue_scripts()\n#9 /v in /var/www/tsite/wp-content/plugins/woocustomizer-pro/includes/customizer/styles.php on line 1142

    Can you please fix this as I want to apply the latest Woocommerce version that has security fixes in it for several known vulnerabilities.

    Thank you in advance.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Thread Starter ttoaster

    (@ttoaster)

    Any news, updates on this, please?

    Plugin Author Kaira

    (@kaira)

    Hi @ttoaster

    Apologies for not seeing this sooner, and thanks for making me aware of this issue.

    I will fix it and post the update as soon as possible.

    Apologies for the inconvenience you’ve experienced.

    Thanks
    Zack

    Thread Starter ttoaster

    (@ttoaster)

    Hi Zack,

    Thank you, I did also send you the information about this issue via your website…

    I look forward to seeing the fixed version.

    Regards,
    Martin

    Plugin Author Kaira

    (@kaira)

    Hi @ttoaster

    I’m looking into this now… I’m testing the update but I’m not getting the same error.

    I’m going to reply to your support request now and take it from there as I’d like to look into why exactly you’re getting the error and fix it on your site.

    Thanks

    Plugin Author Kaira

    (@kaira)

    Glad to hear that code change worked… I’ll add this fix to the next update and post it this week.

    Thank you for help me fix this 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.