Support » Plugin: Flexible Shipping for FedEx and WooCommerce » critical error when used with cache

  • Resolved paulgros

    (@paulgros)


    Hi,

    I’m seeing an issue with the plugin on a Kinsta hosted site. When cache is disabled the plugin works as expected. With caching enabled then the plugin does not connect to the API and throws a critical error from the basket or checkout page as follows:

    Uncaught Error: Class name must be a valid object or a string in /www/marmotorsportcom_989/public/wp-content/plugins/flexible-shipping-fedex/vendor_prefixed/jeremy-dunn/php-fedex-api-wrapper/src/FedEx/AbstractComplexType.php:160 Stack trace: #0 /www/marmotorsportcom_989/public/wp-content/plugins/flexible-shipping-fedex/vendor_prefixed/jeremy-dunn/php-fedex-api-wrapper/src/FedEx/RateService/Request.php(32): FedExVendor\FedEx\AbstractComplexType->populateFromStdClass(Object(stdClass)) #1 /www/marmotorsportcom_989/public/wp-content/plugins/flexible-shipping-fedex/vendor_prefixed/wpdesk/fedex-shipping-service/src/FedexShippingService/FedexApi/FedexSender.php(89): FedExVendor\FedEx\RateService\Request->getGetRatesReply(Object(FedExVendor\FedEx\RateService\ComplexType\RateRequest)) #2 /www/marmotorsportcom_989/public/wp-content/plugins/flexible-shipping-fedex/vendor_prefixed/wpdesk/fedex-shipping-service/src/FedexShippingService/FedexShippingService.php(132): FedExVendor\WPDesk\FedexShippingService\FedexApi\FedexSe in /www/marmotorsportcom_989/public/wp-content/plugins/flexible-shipping-fedex/vendor_prefixed/jeremy-dunn/php-fedex-api-wrapper/src/FedEx/AbstractComplexType.php on line 160

    The above error was given with all plugins disabled except woocommerce. My host has tried bypassing caching, but still no joy.

    Regards,
    Paul

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Hi,
    Same problem here. Just moved to Kinsta yesterday and this problem started. They told me that they use full page Nginx cache. It would be good if you fix the plugin to work properly with this kind of caching.
    For now, I asked them to disable caching in my hosting but this have a big impact to our site performance.
    Thanks

    Plugin Support grzegorzturbasa

    (@grzegorzturbasa)

    Hello,
    thank you for sharing your problem. The issue that you’re experiencing seems to be connected to the OPCache engine on your server. To make sure that our plugin works correctly – and get rid of the given error – please disable opcache.save-comments directive. You can read more about it here: https://www.php.net/manual/en/opcache.configuration.php#ini.opcache.save-comments

    I hope that provided solution will be helpful.

    Kind Regards,
    Greg

    Hi,

    I’ve asked Kinsta support team and they tell me that the opcache_save.comments is set to 0 on Kinsta live environments.

    Is there any other thing we can check?

    Thanks

    Plugin Contributor Grzegorz Rola

    (@grola)

    Hi,

    it should be set to 1, which means: disable discarding comments from code.

    Best regards
    Grzegorz

    Plugin Support Marta Pawlonka

    (@martapaw)

    As we haven’t got any replies, I’m marking this topic as resolved for now.

    andreu

    (@andreu)

    Hi,
    Sorry, I forgot to confirm that the issue is fixed now.
    Thanks for your support!

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.