Support » Plugin: Easy Table of Contents » Critical error when publishing/saving drafts

  • Resolved aquasp

    (@aquasp)


    [05-May-2022 17:27:36 UTC] PHP Fatal error:  Uncaught Error: Call to a member function getTOC() on null in /home/%USER/public_html/wp-content/plugins/easy-table-of-contents/easy-table-of-contents.php:609
    Stack trace:
    #0 /home/%USER/public_html/wp-includes/class-wp-hook.php(307): ezTOC::the_content('\n<p>To write a ...')
    #1 /home/%USER/public_html/wp-includes/plugin.php(189): WP_Hook->apply_filters('\n<p>To write a ...', Array)
    #2 /home/%USER/public_html/wp-content/plugins/link-whisper-premium/core/Wpil/Report.php(1247): apply_filters('the_content', '<!-- wp:paragra...')
    #3 /home/%USER/public_html/wp-content/plugins/link-whisper-premium/core/Wpil/Report.php(985): Wpil_Report::process_content('<!-- wp:paragra...')
    #4 /home/%USER/public_html/wp-content/plugins/link-whisper-premium/core/Wpil/Report.php(2026): Wpil_Report::getContentLinks(Object(Wpil_Model_Post))
    #5 /home/%USER/public_html/wp-content/plugins/link-whisper-premium/core/Wpil/Post.php(653): Wpil_Report::stored_link_content_changed(Object(Wpil_Model_Post))
    #6 /home/%USER/public_ht in /home/%USER/public_html/wp-content/plugins/easy-table-of-contents/easy-table-of-contents.php on line 609

    So, this is the log basically. Seems like it is a conflict with link-whisper-premium?

    I can publish/edit easily after disabling easy TOC.

    Thanks!

Viewing 10 replies - 1 through 10 (of 10 total)
  • i agree this last update causes a pile on conflict

    mine was with RankMath

    Seems to be conflicting with a LOT of plugins. Completely crashes my server after the update.

    Conflict with Link Whisper Pro, and that’s just the plugin that revealed it.

    I got an immediate ‘white screen of death’ this morning on the new version upload, then it seemed to go away.

    I kept nagging at Link Whisper, who then suggested trying a little troubleshooting.

    The fault definitely lies with ETOC.

    I have the same issue here. Spend 2 hours to figure out this plugin is causing the problem.
    Are they working to fix it?

    Also experiencing this issue, but no idea what the conflicting plugin is.

    Plugin Author Magazine3

    (@magazine3)

    We are extremely sorry for the inconvenience.

    We are fixing the bug as we speak and pushing the update in few minutes.

    Plugin Author Magazine3

    (@magazine3)

    We are extremely sorry for the inconvenience we have fixed the issue, will you please update our plugin to the latest version 2.0.21, and let us know

    Thread Starter aquasp

    (@aquasp)

    Hi,

    That solved the issue. Thanks for the quick and hard work guys!

    Thanks @magazine3 for the quick response.

    SO many variables and possibilities these days with so many plugins needed.

    Plugin Author Magazine3

    (@magazine3)

    Glad to hear it. If you have any other queries or issues, Please create a new topic.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Critical error when publishing/saving drafts’ is closed to new replies.