• Resolved mooer

    (@mooer)


    When opening a specific page in the editor, I get the “There has been a critical error on your website” error message. The page is still accessible even though I can’t edit it. When Wordfence is disabled, I can edit it just fine.

    Wierd thing is that earlier today I had the same problem with the Spectra plugin – the same page could not be edited while Spectra was active, but worked fine once deactivated. However, with Spectra enabled and two other plugins disabled (Wordfence Security and WP Content Copy Protection & No Right Click) the error message was shown for a couple of seconds, but after that the page editor was working.

    I contacted Spectra support, who sugguested that I disabled the “template kit button” in the Spectra settings, which resolved the issue.

    After that, I’ve been working on my page when all of a sudden I could not update my page, and when I tried to re-enter it I got the “There has been a critical error on your website” error message again. I’ve tried to delete Wordfence and reinstall it, but the problem remains.

    /mooer

Viewing 5 replies - 1 through 5 (of 5 total)
  • dimal

    (@dimalifragis)

    Critical error is a cryptic message. Enable debug and see the issue:

    Debugging in WordPress

    Plugin Support wfphil

    (@wfphil)

    Hi @mooer

    The most common cause of this is a site is wanting to use more server RAM memory for PHP processes than is allowed by the web server. Please ask your hosting provider to look at the PHP error logs to find out the cause of the problem.

    Thread Starter mooer

    (@mooer)

    Thanks for your reply,

    To me it seems unlikely that it’s a server RAM issue, cause I tried to “clean up” the page and got rid of several more demanding features but it didn’t work. Then I tried to copy the same code content from the faulty page to a new page, and the new page is working as intended.

    So I guess I could just bypass the problem by using the new page, but it’s somewhat disturbing to keep this unresolved issue.

    Full disclosure – I have no coding/web-knowledge what-so-ever. So I’m not saying you’re wrong and of course I’ll ask my host as you suggested – it just seems unlikely to me.

    Thread Starter mooer

    (@mooer)

    You were right. I reached out to the host provider and they increased the PHP-memory which resolved the issue.

    Thanks for your help.

    Plugin Support wfphil

    (@wfphil)

    Hi @mooer

    Thanks for the update.

Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.