Support » Plugin: WooCommerce » Critical Error when logging in

  • Resolved itgresawebdev

    (@itgresawebdev)


    Woocommerce update crashes with a critical error when attempting to log in. Please help.

    Error dump follows:

    When seeking help with this issue, you may be asked for some of the following information:
    WordPress version 5.9
    Current theme: Divi (version 4.14.7)
    Current plugin: WooCommerce (version 6.2.0)
    PHP version 7.4.27
    
    Error Details
    =============
    An error of type E_ERROR was caused in line 173 of the file /home1/newhome/public_html/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard-setup.php. Error message: Uncaught Error: Call to a member function is_complete() on null in /home1/newhome/public_html/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard-setup.php:173
    Stack trace:
    #0 /home1/newhome/public_html/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard-setup.php(44): WC_Admin_Dashboard_Setup->should_display_widget()
    #1 /home1/newhome/public_html/wp-content/plugins/woocommerce/includes/admin/class-wc-admin-dashboard-setup.php(181): WC_Admin_Dashboard_Setup->__construct()
    #2 /home1/newhome/public_html/wp-content/plugins/woocommerce/includes/admin/class-wc-admin.php(102): include('/home1/newhome/...')
    #3 /home1/newhome/public_html/wp-includes/class-wp-hook.php(307): WC_Admin->conditional_includes(Object(WP_Screen))
    #4 /home1/newhome/public_html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters(NULL, Array)
    #5 /home1/newhome/public_html/wp-includes/plugin.php(474): WP_Hook->do_action(Array)
    #6 /home1/newhome/public_html/wp-admin/includes/class-wp-screen.php(421): d

    The page I need help with: [log in to see the link]

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Support Margaret S. woo-hc

    (@margaretwporg)

    Hi @itgresawebdev

    Thanks for sharing the errors.

    I found the the site https://itgresa.com/ is opening smoothly so the problem is with the admin access.

    Just to confirm – are you able access the dashboard? Is it possible to share the following:

    1. System Status: You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”. Once you’ve done that, paste it here in your response.
    2. Fatal Error Log: Share a copy of any fatal error log found under WooCommerce > System Status > Logs (if available).

    We’ll look forward to hearing from you.

    Hi @itgresawebdev

    The problem has been fixed.
    Please update Disable WooCommerce Bloat plugin to its latest version (2.6.3).

    Plugin Support Margaret S. woo-hc

    (@margaretwporg)

    Awesome! Glad to hear the problem is now fixed.

    Thanks for sharing the solution.

    I’ll go ahead and mark this thread as resolved now. If you have any other questions, feel free to create a new topic.

    Thread Starter itgresawebdev

    (@itgresawebdev)

    Not so fast…! We’re not using that plugin and it is not installed, active or deactivated. So that’s not our problem.

    @itgresawebdev

    Sorry, I was nearly sure that is the problem.

    Please post your system status, as @margaretwporg wrote.
    Are you using any custom code for blocking WooCommerce Admin? Could you please show me your functions.php file?

    Plugin Support Margaret S. woo-hc

    (@margaretwporg)

    Hi @itgresawebdev

    Apologies for the confusion. I missed noticing that the update “The problem has been fixed” was not from the thread starter.

    It is true that updating the Disable WooCommerce Bloat plugin to its latest version has helped a number of users with a similar problem since yesterday after the latest WooCommerce update. However, everyone’s case need not necessarily be the same. Kindly send the SSR so we can investigate deeper.

    Thanks @ospiotr for your updates, especially it has been helpful for many users on this thread: https://wordpress.org/support/topic/critical-error-with-woocommerce-6-2/ Thanks! 🙂

    Thread Starter itgresawebdev

    (@itgresawebdev)

    hey, @ospiotr! The system log is in one of my earlier posts.

    here is the functions.php from the wp-includes directory: `

    { large paste has been removed by moderator,
    this is standart WordPress file and its not needed to post it content.

    [Large code excerpt removed by moderator per our FAQ. Please use Pastebin or a Gist for all large code excerpts, they work better anyway.]
    }

    • This reply was modified 4 months, 2 weeks ago by Yui.
    • This reply was modified 4 months, 2 weeks ago by Yui. Reason: formatting
    • This reply was modified 4 months, 2 weeks ago by Yui. Reason: formatting
    Moderator Yui

    (@fierevere)

    ゆい

    functions.php file was meant to THEME’s function.php file (if you have modified it)

    Plugin Support 3 Sons Development – a11n

    (@3sonsdevelopment)

    Hey @itgresawebdev,

    The system log is in one of my earlier posts

    Thanks! We’re actually looking for something different from the error logs. We’re looking for the system status report. You can find it via WooCommerce > Status. Select “Get system report” and then “Copy for support”. Once you’ve done that, you can paste it here.

    Thanks!

    Plugin Support Margaret S. woo-hc

    (@margaretwporg)

    We haven’t heard back from you in a while, so I’m going to mark this thread as resolved – we’ll be here if and/or when you are ready to continue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.