• Resolved Lepalois

    (@lepalois)


    Hello, since the last update I can no longer edit the accounts. I have a critical error.

    Fatal error: Uncaught TypeError: str_replace(): Argument #2 ($replace) must be of type string when argument #1 ($search) is a string in /home/xxx/clubalpinpau.fr/wp-content/plugins/user -registration/includes/class-ur-emailer.php:660 Stack trace: #0 /home/xxx/clubalpinpau.fr/wp-content/plugins/user-registration/includes/class-ur-emailer.php(660) : str_replace() #1 /home/xxx/clubalpinpau.fr/wp-content/plugins/user-registration/includes/class-ur-emailer.php(440): UR_Emailer::parse_smart_tags()

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Support Amrit Kumar Shrestha

    (@shresthauzwal)

    Hi @lepalois,

    Could you please elaborate on your issue more clearly? If you provide us with the exact steps to replicate the case, we can look into it in our testing environment and get back to you accordingly.

    Regards!

    Thread Starter Lepalois

    (@lepalois)

    Hello , thank you for your very fast support.
    I can edit accounts that were created before the update, but all accounts that were created after the update.
    I have a critical error as soon as I update the count.
    Sorry for my english

    francescomion

    (@francescomion)

    I have the same problem of @lepalois.

    After the last update on 14/11/2022, I can’t change the members’ roles and it’s a big problem for registering on my website.

    The error is the same:
    TypeError: str_replace(): Argument #2 ($replace) must be of type string when argument #1 ($search) is a string

    I need to solve it as soon as possible, please.

    Plugin Support Amrit Kumar Shrestha

    (@shresthauzwal)

    Hi @francescomion and @lepalois,

    We will release the plugin update today to resolve the issue. Please update the plugin and check whether the issue is resolved or not.

    Regards!

    francescomion

    (@francescomion)

    Hi @shresthauzwal, thanks for the good news.

    I await the update. After the release, will I be able to update it from WordPress like a normal plugin?

    francescomion

    (@francescomion)

    Hi @shresthauzwal, I saw the update, but there is still the error!

    The plugin now is in 2.2.5 version, but if I try to change the role of a member I get the same error:

    TypeError: str_replace(): Argument #2 ($replace) must be of type string when argument #1 ($search) is a string

    So the new version doesn’t resolve it. Could you resolve it as soon as possible?

    Please, thanks to the availability

    Plugin Support Amrit Kumar Shrestha

    (@shresthauzwal)

    Hi @francescomion,

    We tested the update extensively before releasing it. The most recent update is fully functional here. There seems to be a conflict between the plugins (especially role editor plugins). Could you please refer to this documentation https://docs.wpeverest.com/user-registration/docs/how-to-check-plugin-theme-conflict/ and follow the instruction kindly? This will let you know the cause of the error.

    Regards!

    Plugin Support Amrit Kumar Shrestha

    (@shresthauzwal)

    Hi @francescomion,

    Since we did not get a response from your end, we are marking this thread as resolved as we believe the things mentioned here are now resolved. Please create a new support thread if needed.

    Thanks!

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.