Support » Plugin: Elementor Addons - PowerPack Addons for Elementor » Critical error in PowerPack Lite when updating Elementor

  • Resolved frankmanl

    (@frankmanl)


    I have Elementor and Elementor PRO installed,
    Updating Elementor to 3.0.0 caused a critical error.

    Uncaught Error: Class 'Elementor\TemplateLibrary\Source_Base' not found in /home/vhosts/po../wp-content/plugins/powerpack-lite-for-elementor/classes/class-pp-templates-lib.php:514
    Stack trace:
    #0 /home/vhosts/po../wp-content/plugins/powerpack-lite-for-elementor/powerpack-lite-elementor.php(30): require_once()
    #1 /home/vhosts/po../wp-settings.php(377): include_once('/home/vhosts/po...')
    #2 /home/vhosts/po../wp-config.php(95): require_once('/home/vhosts/po...')
    #3 /home/vhosts/po../wp-load.php(37): require_once('/home/vhosts/po...')
    #4 /home/vhosts/po../wp-admin/admin.php(34): require_once('/home/vhosts/po...')
    #5 /home/vhosts/po../wp-admin/update.php(16): require_once('/home/vhosts/po...')
    #6 {main}
      thrown

    Power Pack Lite now deactivated, site is OK again, but this may need attention.
    Frank

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Contributor Nirbhay Singh

    (@nirbhay18)

    Hi @frankmanl,

    Are you using the beta version of Elementor?

    Hi Nirbhay, no, it was latest version of Elementor (2.9.13 or 14), in combination with Elementor Pro.
    WP told me there was an update for Elementor, which I installed: 3.0.0.
    No beta version as far as I know.
    Since then everything went wrong, my site is offline now (no worries, it was not in production yet) and my host will restore a backup for me coming night.
    If you did not get any other alerts about this, I suggest you let it be.
    I can’t help you with any other information anyway.
    Thanks for your reply, Frank

    Plugin Contributor Nirbhay Singh

    (@nirbhay18)

    Hi @frankmanl,

    Can you try upgrading PowerPack to the latest version? It should fix the issues.

    frankmanl

    (@frankmanl)

    Sorry Nirbhay, I don’t have it installed anymore, and will not install it again (I was testing things with it, but don’t need it).
    Elementor just released a fix for their version 3.0.0 – there were obviously some isues with that release.
    Hope your plugin works fine now, thanks for your support.
    Frank

    Plugin Contributor Nirbhay Singh

    (@nirbhay18)

    @frankmanl

    I understand the concern. With major updates, there are always unpredictable issues and we are working round the clock to resolve them as they come by.

    Happy to learn that you tried PowerPack. I hope we will see you using it again soon.

    Have a good day 🙂

    Plugin Author Simrandeep Singh

    (@simrandeep)

    Hi @frankmanl

    With the latest Elementor and Elementor Pro, the issues are resolved now.

    Thank you

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.