Support » Plugin: Geolocation IP Detection » Critical error in conjunction with toolset

  • Resolved coholm

    (@coholm)


    I got the following error after saving settings in toolset:

    Ein Fehler vom Typ E_ERROR wurde in der Zeile 29 der Datei /home/www/wordpress/wp-content/plugins/geoip-detect/vendor/symfony/polyfill-php80/bootstrap.php verursacht. Fehlermeldung: Uncaught TypeError: Argument 1 passed to str_contains() must be of the type string, null given, called in /home/www/wordpress/wp-content/plugins/woocommerce-views/application/Helpers/Template_Settings_Translator.php on line 44 and defined in /home/www/wordpress/wp-content/plugins/geoip-detect/vendor/symfony/polyfill-php80/bootstrap.php:29
    Stack trace:
    #0 /home/www/wordpress/wp-content/plugins/woocommerce-views/application/Helpers/Template_Settings_Translator.php(44): str_contains(NULL, '/home/www/wordp...')
    #1 /home/www/wordpress/wp-content/plugins/woocommerce-views/application/Settings/Sections/Legacy_Templates.php(64): WooViews\Helpers\Template_Settings_Translator->is_theme_template(NULL)
    #2 /home/www/wordpress/wp-content/plugins/woocommerce-views/application/Settings/Frontend.php(88): WooViews\Settings\Sections\Legacy_Templates->is_enabled()
    #3 /home/www/wordpress/wp-content/plugins/woocommerce-views/application/Settings/Frontend.php(62): WooViews\Settings\Frontend->register_sections()
    #4 /home/www/wordpre in /home/www/wordpress/wp-content/plugins/geoip-detect/vendor/symfony/polyfill-php80/bootstrap.php on line 29
    • This topic was modified 7 months ago by coholm.
    • This topic was modified 7 months ago by coholm.
Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Author Benjamin Pick

    (@benjaminpick)

    Probably the plugin is defining its own version of str_contains, which now has become a function in PHP 8 – so the plugin probably doesn’t work in PHP 8.

    Here is a similar issue:
    https://github.com/symfony/symfony/issues/37035

    I will remove the typehint for now but upgrading your site to PHP 8 will only be possible if toolset supports it …

    Can you try 4.2.0-beta1 please?

    https://github.com/yellowtree/geoip-detect/wiki/Beta-Testing

    Thread Starter coholm

    (@coholm)

    Thanks for your quick feedback. I have installed the beta version, but the problem still occurs. (Version 4.2.0-beta1)

    Fatal error: Uncaught TypeError: Argument 1 passed to Symfony\Polyfill\Php80\Php80::str_contains() must be of the type string, null given, called in /home/www/testenv2/wp-content/plugins/geoip-detect/vendor/symfony/polyfill-php80/bootstrap.php on line 29 and defined in /home/www/testenv2/wp-content/plugins/geoip-detect/vendor/symfony/polyfill-php80/Php80.php:91 Stack trace: #0 /home/www/testenv2/wp-content/plugins/geoip-detect/vendor/symfony/polyfill-php80/bootstrap.php(29): Symfony\Polyfill\Php80\Php80::str_contains(NULL, '/home/www/teste...') #1 /home/www/testenv2/wp-content/plugins/woocommerce-views/application/Helpers/Template_Settings_Translator.php(44): str_contains(NULL, '/home/www/teste...') #2 /home/www/testenv2/wp-content/plugins/woocommerce-views/application/Settings/Sections/Legacy_Templates.php(64): WooViews\Helpers\Template_Settings_Translator->is_theme_template(NULL) #3 /home/www/testenv2/wp-content/plugins/woocommerce-views/application/Settings/Frontend.php(88): WooViews\Settings\Sections\Legacy_Templates- in /home/www/testenv2/wp-content/plugins/geoip-detect/vendor/symfony/polyfill-php80/Php80.php on line 91

    Plugin Author Benjamin Pick

    (@benjaminpick)

    Ah, ok … try again now (beta2) …

    Thread Starter coholm

    (@coholm)

    Seems to be fixed. Thank you!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Critical error in conjunction with toolset’ is closed to new replies.