Support » Plugin: CF7 Google Sheets Connector » Critical Error (guzzle ssl) when submitting

  • Resolved tristyb

    (@tristyb)


    Hi there

    I’m having an issue getting the plugin to submit.

    When I submit my form I am told “There has been a critical error on this website.”.

    To reproduce –

    • Fill in the form and choose injury as your reason (this is the only page currently setup)
    • Scroll down the page and click the red cancel button (this will then submit the contact form 7 form via API).
    • Error occurs

    The error log has this to say:

    [22-Aug-2021 04:24:19 UTC] PHP Fatal error:  Uncaught GuzzleHttp\Exception\ConnectException: cURL error 35: error:14094410:SSL routines:ssl3_read_bytes:sslv3 alert handshake failure (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://www.WEBSITE-NAME.com/wp-json/contact-form-7/v1/contact-forms//feedback in /home/customer/www/WEBSITE-NAME/public_html/deploy/releases/gym-cms-1629023661593/bedrock/web/app/plugins/cf7-google-sheets-connector/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php:210
    Stack trace:
    #0 /home/customer/www/WEBSITE-NAME.com/public_html/deploy/releases/gym-cms-1629023661593/bedrock/web/app/plugins/cf7-google-sheets-connector/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(158): GuzzleHttp\Handler\CurlFactory::createRejection(Object(GuzzleHttp\Handler\EasyHandle), Array)
    #1 /home/customer/www/WEBSITE-NAME/public_html/deploy/releases/gym-cms-1629023661593/bedrock/web/app/plugins/cf7-google-sheets-connector/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php(110): GuzzleHttp\Handler in /home/customer/www/WEBSITE-NAME.com/public_html/deploy/releases/gym-cms-1629023661593/bedrock/web/app/plugins/cf7-google-sheets-connector/lib/vendor/guzzlehttp/guzzle/src/Handler/CurlFactory.php on line 210
    

    I am wondering if it is hosting related as on my local development site this doesn’t happen but on the live site (Siteground) it does. I have tried disabling all other plugins, reinstalling and removing permissions and getting a new code to no avail. Contact Form 7 is up to date and I have tried versions 4.6 and 4.7 of your plugin.

    Any help much appreciated 🙂

    Thanks

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author westerndeal

    (@westerndeal)

    Hi @tristyb,

    It seems either Curl is not enabled for the PHP version that your hosting server has provided.

    As you have also open up ticket at our web support. Can you send the whole error to us to guide you further.

    Thanks
    Abdullah.

    Thread Starter tristyb

    (@tristyb)

    Thanks for getting back to me. I’ve emailed you outside of WordPress.org.
    Hopefully we can reply here with an answer if we find one.

    Thread Starter tristyb

    (@tristyb)

    Thank you for helping me over email.

    It turns out this was caused by an issue in my code and in the fact that my hosting provider had an nginx cache on which was obscuring the real error in the logs.

    I would consider this issue resolved and not an issue with the plugin at all which is now working brilliantly.

    Thanks again.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Critical Error (guzzle ssl) when submitting’ is closed to new replies.