Support » Plugin: WooCommerce » Critical Error with Version 4.8.0

  • Resolved 2C742B5F

    (@e5223959880)


    Hi, we have updated to the latest version of the WooCommerce plugin on our staging site and receive this error upon looking at the error log:

    An error of type E_COMPILE_ERROR was caused in line 24 of the file /var/www/wp-content/plugins/woocommerce/woocommerce.php. Error message: require(): Failed opening required ‘/var/www/wp-content/plugins/woocommerce/src/Autoloader.php’ (include_path=’.:/opt/remi/php73/root/usr/share/pear:/opt/remi/php73/root/usr/share/php:/usr/share/pear:/usr/share/php’)

    How to fix this?

    • This topic was modified 1 year, 6 months ago by 2C742B5F.
Viewing 5 replies - 1 through 5 (of 5 total)
  • upgrading your php to 7.4 might help

    I am having the same issue. Site is completely offline now, I don’t have any backup as well πŸ™

    Plugin Support zdenys

    (@zdenys)

    Hi there @e5223959880!

    I think the error indicates either a missing file or a missing file permission. Can you try and manually reinstall WooCommerce by copying over the files via FTP replacing the ones on your server.

    Does that change anything?

    P.S.: @maahad767 next time please make sure to start a separate thread for any issues so we can deal with each individual case separately. Thanks!

    I’m looking forward to hearing from you to assist you further.

    Plugin Support Mike a11n

    (@nixiack8)

    Hi all,

    Did the option above work for you? Please let us know πŸ™‚

    Thread Starter 2C742B5F

    (@e5223959880)

    All good. Update is fine πŸ™‚

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Critical Error with Version 4.8.0’ is closed to new replies.