Support » Fixing WordPress » critical error following an update: site inaccessible

  • Resolved spunky08

    (@spunky08)


    Hi everyone !

    Today I need your help because my site is broken…
    And.. Pardon my french ^^

    This morning, I received this email :

    Your site at https://www.spunky-crea.fr faced a critical failure when trying to update to the latest version of WordPress, 5.4.2.

    This means that your site may be offline or broken. Don’t panic, it can be fixed.

    Please check your site immediately. It may be that everything works. If he shows that you need to update, you should follow his advice:
    https://www.spunky-crea.fr/wp-admin/update-core.php

    If you run into problems or need assistance, the helpdesk support volunteers at wpfr.net should be able to help.
    https://wordpress.org/support/forums/

    For security reasons, it is important to keep your site up to date. It also makes the web safer for you and your readers.

    The WordPress team

    ***

    Your site uses version 5.4.1. We have some data that describes the error your site encountered. Your host, support forum volunteers or a developer friend should be able to help you understand this information to help you:

    Error code: copy_failed__copy_dir_retry
    The file could not be copied.
    wp-includes / images / w-logo-blue-white-bg.png

    I tried to go on the link to fix the problem but nothing happen, except this message :
    A critical error has occurred on your site. Please check the inbox of your site’s administration email for more information.

    The same message appears when I want to access my wp-admin.

    What should I do to get my site up and running again?

    I am a beginner in web development so I apologize in advance if I don’t understand all the advice you will give me :$

    Thanks in advance !

    Sarah

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • I have exactly the same error on one of my website.
    I follow the topic …

    Hello,

    Same error on my site after the WP auto update.
    I can’t login on wp-admin but I activated the debug mode and get this :

    [11-Jun-2020 10:31:51 UTC] PHP Fatal error: Uncaught Error: Class ‘WP_Comment_Query’ not found in /home/poslont/www/wp-includes/comment-template.php:1462
    Stack trace:
    #0 /home/poslont/www/wp-content/themes/bellevuex/page.php(18): comments_template(‘/templates/comm…’)
    #1 /home/poslont/www/wp-content/themes/bellevuex/base.php(130): include(‘/home/poslont/w…’)
    #2 /home/poslont/www/wp-includes/template-loader.php(106): include(‘/home/poslont/w…’)
    #3 /home/poslont/www/wp-blog-header.php(19): require_once(‘/home/poslont/w…’)
    #4 /home/poslont/www/index.php(17): require(‘/home/poslont/w…’)
    #5 {main}
    thrown in /home/poslont/www/wp-includes/comment-template.php on line 1462

    Hope someone can help us soon πŸ™‚

    Same issue here. After downloading a plugin (WP avatar) I see the following on the screen.

    “There has been a critical error on your website. Please check your site admin email inbox for instructions.

    Learn more about debugging in WordPress.”

    I am able to see my site. But unable to get to my dashboard. Haven’t received any email into account that is registered with Worldpress.org accounts.

    I can see my website but cannot make any changes.

    Can someone please help?

    Same error message on my side:

    Error code: copy_failed__copy_dir_retry
    The file could not be copied.
    wp-includes / images / w-logo-blue-white-bg.png

    I have uploaded through FTP a 5.4.2 version (except wp-content and wp-config.php file) and it works fine now.

    Hope it helps.

    Hi @vins1892

    I think I am already on 5.4.2. I just started a couple of days ago and hence the latest version.

    Honestly being a non-technical person it’s difficult for me digest the FTP stuff. I logged into my cPanel (goDaddy) to check but not sure where to get 5.4.2 files and into which directory in the File Manager I should put them.

    I did search my Mac for Debug files, WP-config or any WP related file. Nothing of that sort came up. I see a lot of Avada files that are in my downloads folder (not Application folder) because I am using Avada.

    No idea where to re-start. I just needed to develop a simple 5-6 page Website for my business consulting firm. Based on whatever I read on the internet I thought I could do it myself. May I made a mistake getting into this website development stuff.

    My website is nagurala.com. Grateful for any help. Otherwise let me know if there is some technical expert in Bangalore that I can talk to. Thanks

    I did what @vins1892 did and it works for me.
    Thanks

    Hi all

    Finally managed to solve this by removing the offending plugin wp-avatar. Looks like it is incompatible with version 5.4.2.

    Went to cPanel File manager, searched for wp-avatar and deleted all the files in that directory.

    Although I changed the settings to enable the debug mode did not see any log files.

    I am back on track now and getting a bit of hands on tech side:-)

    • This reply was modified 2 years, 6 months ago by nag007urala.
    Thread Starter spunky08

    (@spunky08)

    Hello
    @vins1892, how did you upload through FTP a 5.4.2 version ?

    Thread Starter spunky08

    (@spunky08)

    I did it !
    It works ! Hurray !
    Thanks for your help πŸ™‚

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘critical error following an update: site inaccessible’ is closed to new replies.