• I am not sure if you are aware, but after latest elemntor updates, i get a critical error when trying to edit any page with elementor. I disabled plugins one by one and identified the conflict to be with wpglobus. Also, i activated debug and this is what it says:

    Fatal error: Uncaught Error: Call to a member function add_feature() on null in /home/upfrro/public_html/ro/wp-content/plugins/elementor/modules/gutenberg/module.php:146 Stack trace: #0 /home/upfrro/public_html/ro/wp-content/plugins/elementor/modules/gutenberg/module.php(136): Elementor\Modules\Gutenberg\Module->register_experiments() #1 /home/upfrro/public_html/ro/wp-content/plugins/wpglobus/includes/builders/class-wpglobus-builders.php(1148): Elementor\Modules\Gutenberg\Module->__construct() #2 /home/upfrro/public_html/ro/wp-content/plugins/wpglobus/includes/builders/class-wpglobus-builders.php(935): WPGlobus_Builders::get_3rd_party_status_for_gutenberg(true, 'page') #3 /home/upfrro/public_html/ro/wp-content/plugins/wpglobus/includes/builders/class-wpglobus-builders.php(343): WPGlobus_Builders::is_gutenberg() #4 /home/upfrro/public_html/ro/wp-content/plugins/wpglobus/includes/builders/class-wpglobus-config-builder.php(72): WPGlobus_Builders::get(true, Array) #5 /home/upfrro/public_html/ro/wp-content/plugins/wpglobus/inc in /home/upfrro/public_html/ro/wp-content/plugins/elementor/modules/gutenberg/module.php on line 146
    
    Notice: Funcția is_embed a fost apelată incorect. Etichetele de interogare condiționale nu funcționează înainte ca interogarea să fie pornită. Înainte de aceasta, întorc întotdeauna o valoare falsă. Te rog vezi Depanare în WordPress pentru mai multe informații. (Acest mesaj a fost adăugat în versiunea 3.1.0.) in /home/upfrro/public_html/ro/wp-includes/functions.php on line 5905
    
    Notice: Funcția is_search a fost apelată incorect. Etichetele de interogare condiționale nu funcționează înainte ca interogarea să fie pornită. Înainte de aceasta, întorc întotdeauna o valoare falsă. Te rog vezi Depanare în WordPress pentru mai multe informații. (Acest mesaj a fost adăugat în versiunea 3.1.0.) in /home/upfrro/public_html/ro/wp-includes/functions.php on line 5905
    
    A fost o eroare critică pe acest site web. Pentru instrucțiuni, te rog vezi emailurile primite de administratorul site-ului.

    For now, i downgraded Elementor to 3.16.6 version, and i can edit my pages.

    • This topic was modified 8 months, 3 weeks ago by mihailmc.
Viewing 15 replies - 1 through 15 (of 17 total)
  • HI facing same problem with elementor 3.17.1, elemento pro 3.17 element kitelight 3.0, essential addon for elementor 5.8.3

    Please fix it ASAP!!

    Hello, I have the same problem using Elementor 3.17.1 in combination with WPGlobus 2.12.2 and WPGlobus Plus 1.8.7.

    If I reset Elementor to 3.16.6 everything works again.

    I can confirm the incompatibility with elementor 3.17.1 and WPGlobus 2.12.2.

    Rollback did the trick.

    • This reply was modified 8 months, 2 weeks ago by highlive.
    Thread Starter mihailmc

    (@mihailungu)

    The latest update for wpglobus was like 5 months ago…how long should we wait for a fix? Switching from wpglobus to another language plugin is a pain in the….

    • This reply was modified 8 months, 2 weeks ago by mihailmc.

    Same problem here, had to rollback elementor. Can you update this plugin? if I have to choose, I’ll need to chose elementor but will hate using other plugin for translated pages.

    Thread Starter mihailmc

    (@mihailungu)

    I would gladly use other translate plugin, but getting rid of WPglobus is a big pain in the…. Why? Because the way it is working, by adding those language tags like {en}. I know there is a cleanup tool inside wpglobus, but that would mean i would have to recreate from 0 all my EN pages and for a big site, it would take me at least 1 week. But, seeing that after 2 weeks, the DEVs do not even bother to answer to this topic, i guess this is the kick in the butt i needed to start replacing WPglobus.

    webdes44

    (@webdes44)

    Same problem here.

    ccotal

    (@ccotal)

    HI, rolling back fixed the issue. but now, the language switcher is not working, only one language is displayed.

    Do you have any suggestion to fix that?

    Did someone tried to move from wpglobus to wpml? How to proceed?

    Also the same problem.. If someone finds an alternative solution, please let me know.

    Thread Starter mihailmc

    (@mihailungu)

    2 months later and no fix… I can’t even switch to other multilanguage plugin. Besides the need to remove language tags and re-do en pages, it seems that deactivating WP Globus also scrambles my Elementor RO pages !!! This is a nightmare. I am stuck with Elemntor V 3.16.6 and this stupid WP Globus plugin!!!

    • This reply was modified 6 months, 1 week ago by mihailmc.

    Same thing. I have to deactivate this plugin and I’ll modify every single page on the website. WTF

    Thread Starter mihailmc

    (@mihailungu)

    Hi all,

    If you see this, i also posted on Elementor support forum, perhaps they can help out. Here is the link if you would like to comment, and ask them to help us. Perhaps if they see more people stuck with this error, they might suggest some fixes.

    https://wordpress.org/support/topic/critical-error-elementor-wpglobus-2

    I fixed this by rolling back elementor 3.16.0 and Wp globus  2.12.2

    Unfortunately, this is only a temporary solution. Does anyone know how to remove the whole Wp globus without the page template sliding apart?

    Thread Starter mihailmc

    (@mihailungu)

    You can try using the uninstaller from wpglobus options. This will remove the language tags from database. But on my case, even if i used this option, my main language pages were broken too…somehow all the containers were merge into a single one. So, i let the site as it is, with elementor 3.16.6 and wpglobus and i cloned the site. On the clone i removed wpglobus and rebuilt my main scrambled language pages using copy (from the live site) > paste option (from another site to clone without wpglobus) in elementor. After everything was rebuild on the clone, i removed the live website and made the clone as main live site. It was like 20 hours of work, but in the end i got rid of this stupid wpglobus plugin.

    • This reply was modified 4 months ago by mihailmc.
    • This reply was modified 4 months ago by mihailmc.
Viewing 15 replies - 1 through 15 (of 17 total)
  • You must be logged in to reply to this topic.