Support » Plugin: Photo Gallery by Supsystic » Critical error due to plugin update 1.14.8 / 2.8.7 (PRO)

  • Resolved Lavisch

    (@lavisch)


    Hi there,

    The latest update to version 1.14.8 / 2.8.7 (PRO) has created a critical error on my website:

    Fatal error: Uncaught Error: Class ‘Twig_SimpleFunction’ not found in /var/www/vhosts/dyskolus.com/httpdocs/site/lavisch/wp-content/plugins/supsystic-gallery-pro/src/GridGalleryPro/Galleries/Module.php:400 Stack trace: #0 /var/www/vhosts/dyskolus.com/httpdocs/site/lavisch/wp-content/plugins/gallery-by-supsystic/src/GridGallery/Galleries/Module.php(20): GridGalleryPro_Galleries_Module->registerShortcode() #1 /var/www/vhosts/dyskolus.com/httpdocs/site/lavisch/wp-content/plugins/supsystic-gallery-pro/src/GridGalleryPro/Galleries/Module.php(23): GridGallery_Galleries_Module->onInit() #2 /var/www/vhosts/dyskolus.com/httpdocs/site/lavisch/wp-content/plugins/gallery-by-supsystic/vendor/Rsc/Resolver.php(103): GridGalleryPro_Galleries_Module->onInit() #3 /var/www/vhosts/dyskolus.com/httpdocs/site/lavisch/wp-content/plugins/gallery-by-supsystic/vendor/Rsc/Environment.php(244): Rsc_Resolver->init() #4 /var/www/vhosts/dyskolus.com/httpdocs/site/lavisch/wp-includes/class-wp-hook.php(287): Rsc_Environment->extend(”) #5 /var/www/vhosts in /var/www/vhosts/dyskolus.com/httpdocs/site/lavisch/wp-content/plugins/supsystic-gallery-pro/src/GridGalleryPro/Galleries/Module.php on line 400

    I’ve also posted this through the support form on supsystic.com.

    Help would be appreciated, since my website doesn’t work right now due to this.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Same problem here. Update or Deactivate the pro version of the plugin.
    As far I understand it’s a way to make you renew your pro subscription.

    • This reply was modified 5 months, 1 week ago by soulg.
    • This reply was modified 5 months, 1 week ago by soulg.

    Updating the pro version of the plugin did the trick. I haven’t tried deactivation 🙂

    Hi
    Same here = Updating to Pro Version 2.8.7 did not solve the crtical error

    supsystic-gallery-pro/src/GridGalleryPro/Galleries/Module.php. Error message: Uncaught Error: Class 'Twig_SimpleFunction' not found

    Daveed

    Upgrading Pro to 2.8.8 not resolving problem. deactivated plugin. Please resolve problem

    Plugin Author supsystic

    (@supsysticcom)

    Due to numerous requests from customers and for compatibility with other plugins, it was decided to update the TWIG libraries.
    Unfortunately, older versions will not be compatible with newer ones. Therefore, to use the latest Free versions of the plugin, you must update the PRO version. Last PRO – 2.8.8

    Best regards,
    Ole

    I have Pro version 2.8.7. Please advise how can I update to 2.8.8?
    I do not have any link in my account on supsystic.com…
    And when I activate the plugin, it crashes my website including wp-admin, so I had to delete files via FTP to restore the access.

    Plugin Support Support Ole

    (@trsupsys)

    This thread for free version plugin.
    Contact us for support on the site.
    Only there we support the PRO version.
    In order for you to have the opportunity to upgrade to the latest versions, you must have an active license that has not expired.

    Best regards,
    Ole

    Thanks for the download link! Updating to v2.8.8 solves the problem instantly and everything works as previously.

    Hi guys,

    I have the same issue, and can’t find out the download link for PRO plugin as well I don’t have response for my messages on site.

    BTW the same problem with Social Share plugin

    Thanks much! Both plugins work fine after manual update, the issue with PRO link was fixed too.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.