Support » Plugin: HTTP Headers » Critical error cannot change settings

  • Hi,

    I cannot change any settings from the plugin anymore, when I do it gives the white WP screen with critical error (but the site loads normally when reloading the page, just can’t save)

    Any idea how to fix this?

    Thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • CroMisho

    (@cromisho)

    Same here. Tested on multiple websites. Here’s the error:

    Fatal error: Uncaught Error: Call to a member function switch_to_locale() on null in /home/customer/www/***.com/public_html/wp-includes/l10n.php:1679 Stack trace: #0 /home/customer/www/***.com/public_html/wp-admin/includes/misc.php(132): switch_to_locale('en_US') #1 /home/customer/www/***.com/public_html/wp-content/plugins/http-headers/http-headers.php(1330): insert_with_markers('/home/customer/...', 'HttpHeaders', Array) #2 /home/customer/www/***.com/public_html/wp-content/plugins/http-headers/http-headers.php(815): update_headers_directives() #3 /home/customer/www/***.com/public_html/wp-includes/class-wp-hook.php(309): http_headers_option('siteground_opti...') #4 /home/customer/www/***.com/public_html/wp-includes/class-wp-hook.php(331): WP_Hook->apply_filters('', Array) #5 /home/customer/www/***.com/public_html/wp-includes/plugin.php(474): WP_Hook->do_action(Array) #6 /home/customer/www/***.com/public_html/wp-includes/option.php(538): do_action('updated_opt in /home/customer/www/***.com/public_html/wp-includes/l10n.php on line 1679

    Thread Starter KVNHNF

    (@kvnhnf)

    Plugin was awesome but sadly seem discontinued…

    Yeah, I am getting the same error:

    Fatal error: Uncaught Error: Call to a member function switch_to_locale() on null in ...\wp-includes\l10n.php:1679 Stack trace: #0 ...\wp-admin\includes\misc.php(132): switch_to_locale() #1 ...\wp-content\plugins\http-headers\http-headers.php(1330): insert_with_markers() #2 ...\wp-content\plugins\http-headers\http-headers.php(815): update_headers_directives() #3 ...\wp-includes\class-wp-hook.php(309): http_headers_option() #4 ...\wp-includes\class-wp-hook.php(331): WP_Hook->apply_filters() #5 ...\wp-includes\plugin.php(474): WP_Hook->do_action() #6 ...\wp-includes\option.php(538): do_action() #7 ...\wp-includes\plugin.php(884): update_option() #8 ...\wp-content\plugins\stop-user-enumeration\stop-user-enumeration.php(50): register_uninstall_hook() #9 ...\wp-content\plugins\stop-user-enumeration\stop-user-enumeration.php(55): Stop_User_Enumeration\run_stop_user_enumeration() #10 ...\wp-settings.php(418): include_once('...') #11 ...\wp-config.php(83): require_once('...') #12 ...\wp-load.php(50): require_once('...') #13 ...\wp-admin\admin.php(34): require_once('...') #14 ...\wp-admin\options.php(19): require_once('...') #15 {main} thrown in ...\wp-includes\l10n.php on line 1679

    Any solutions?

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.