• ludwss

    (@ludwss)


    Hello, I have an issue with my WP website.
    This morning I was trying to import a template, that was a .json file (this template was already loaded in Saved Templates, but I didn’t notice), but this upload generates a critical error (“There has been a critical error on your website”). Since then, I can’t edit any page or posts or create new ones, because the same error keeps popping up.

    Fortunately, it’s the only issue I have; all the rest works well.

    How can I fix it? Thank you very much for your help!

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hello there,

    Please explain further where you are trying to upload the.json file to that triggered this error also send your site address let me check

    Thread Starter ludwss

    (@ludwss)

    I was trying to upload it inside my Theme Builder. Sure, my site is: https://rationalscale.it/

    Can you try to debug, and send the PHP error here… So I can get more clues about the error and how to fix it.

    Also to be sure we are on the same page… Send the screenshot of the error page

    You can use a free image hosting site to upload the screenshot, then send the link here..

    Try – https://imgbb.com/`

    TO DEBUG:
    Look for the WP_DEBUG constant in your wp-config file and set it to true.

    It should look like this:
    define( ‘WP_DEBUG’, true );

    Moderator Steven Stern (sterndata)

    (@sterndata)

    Volunteer Forum Moderator

    @iamsirotee Please use the link https://wordpress.org/support/article/debugging-in-wordpress/ and, if you’re around right now, join us in the Support Team meeting in the #forums channel on Slack.

    Hello @sterndata sorry, I got your message late.

    I tried editing the post to use the resource link but the edit option isn’t coming up again.

    Thread Starter ludwss

    (@ludwss)

    My error in error_log is:

    WordPress database error Deadlock found when trying to get lock; try restarting transaction for query DELETE FROMwp_optionsWHEREoption_name= '_transient_global_styles_hello-elementor' made by require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/hello-elementor/index.php'), get_header, locate_template, load_template, require_once('/themes/hello-elementor/header.php'), wp_head, do_action('wp_head'), WP_Hook->do_action, WP_Hook->apply_filters, wp_enqueue_scripts, do_action('wp_enqueue_scripts'), WP_Hook->do_action, WP_Hook->apply_filters, wp_enqueue_global_styles, wp_get_global_stylesheet, get_transient, delete_option

    What should I do? Thank you very much.

    • This reply was modified 2 years ago by ludwss.
    • This reply was modified 2 years ago by ludwss.

    It means there’s an application that has locked the table because it didn’t finish to update a record in the DB. Because of the lock, Elementor cannot write to that table.
    You would need to try to debug your blog and to find out which application (probably a plugin or theme) is causing this.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Critical Error After Trying To Upload A Template’ is closed to new replies.