• Resolved laserstore

    (@laserstore)


    Hello! The current version, 2.8.1, caused a critical error in my admin panel. I went back to version 2.7 and everything was back to normal. Something I can check?

    Thanks!

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author jordanleven

    (@jordanleven)

    Hey @laserstore, can you send a description of the error you’re seeing along with a screenshot? Additional logs from your server (if you’re seeing an error there) would also be helpful.

    Additionally, please send along the version of PHP and WordPress you’re on. To do that, navigate to Force Refresh on the site running 2.7, click on Troubleshooting, and send a screenshot of what’s there. Thanks!

    • This reply was modified 11 months, 1 week ago by jordanleven.
    Thread Starter laserstore

    (@laserstore)

    Hi Jordan! Thanks for your response!

    I´m using PHP 7.4 and wordpress 6.2.2. Below is part of what I received via email about the error:

    Um erro do tipo E_ERROR foi causado na linha 26 do arquivo /public_html/wp-content/plugins/force-refresh/includes/actions/admin/inc.release-notes.php. Mensagem de erro: Uncaught TypeError: Return value of JordanLeven\Plugins\ForceRefresh\get_plugin_readme() must be an instance of JordanLeven\Plugins\ForceRefresh\mixed, string returned in /public_html/wp-content/plugins/force-refresh/includes/actions/admin/inc.release-notes.php:26 Stack trace: #0 /public_html/wp-content/plugins/force-refresh/includes/actions/admin/inc.release-notes.php(91): JordanLeven\Plugins\ForceRefresh\get_plugin_readme() #1 /public_html/wp-content/plugins/force-refresh/includes/actions/admin/inc.release-notes.php(114): JordanLeven\Plugins\ForceRefresh\get_release_notes_json() #2 /public_html/wp-content/plugins/force-refresh/includes/actions/admin/inc.refresh-ui.php(73): JordanLeven\Plugins\ForceRefresh\get_release_notes() #3 /public_html/wp-content/plugins/force-refresh/includes/actions/admin/inc.refresh-ui.php(91): JordanLeven\Plugins\ForceRefresh\get_localized_data() #4 /public_html/w

    Unfortunately it appears that the email has been cut and the information is not complete. Maybe it could be a conflict with another plugin, but I need to investigate further.

    Thanks!

    Plugin Author jordanleven

    (@jordanleven)

    Hey @laserstore – thanks for getting back to me so quickly! I believe I’ve identified an issue with running Force Refresh with PHP versions below 8.0 and have a fix ready.

    The process for validating this fix involves installing a beta version of the plugin containing the fix. Once I’ve confirmed that the beta version fixes the issue you’re describing, I’ll be releasing this publicly.

    To install, the beta version, please navigate to the Releases section of Force Refresh to install version 2.8.2-788E4D.0. You can download it directly at https://github.com/jordanleven/force-refresh/releases/download/v2.8.2-788E4D.0/Force_Refresh_v2.8.2-788E4D.0.zip.

    Once installed, let me know if this fixes the issue. If it does, you can leave it in place and it’ll automatically be updated to the next version (2.8.2) when you run updates. If it doesn’t fix the issue, let me know what you find.

    Let me know if you have any questions!

    • This reply was modified 11 months, 1 week ago by jordanleven.
    Plugin Author jordanleven

    (@jordanleven)

    @laserstore Quick edit: I just realized that WordPress doesn’t recognize beta builds of plugins (ones ending in -XXXX.0) so quick update if you haven’t already installed the beta version with the fix. Instead of the version I sent, please install version 2.8.1-788E4D.0. You can download it directly at https://github.com/jordanleven/force-refresh/releases/download/v2.8.1-788E4D.0/Force_Refresh_v2.8.1-788E4D.0.zip.

    This fix is identical, but the version is slightly different. Instead of a variant of the 2.8.2 version, it’s a variant of the current 2.8.1 version. This subtle difference is so that once you have the beta version installed, you can update directly to the next version from the WordPress Plugins panel, which will be 2.8.2.

    Thread Starter laserstore

    (@laserstore)

    Hi @jordanleven ! Yes, worked for me! No error occurred.

    Thank you so much!

    Plugin Author jordanleven

    (@jordanleven)

    @laserstore – perfect! I went ahead and released version 2.8.2 which contains the fix. Your beta version will continue to ask to the latest version since it contains a development build of the app and, on average, is larger and less performant than the production build. As soon as you can, please be sure to update to 2.8.2.

    Thanks again for alerting me of the issue and for your willingness to troubleshoot. Let me know if you have any other questions or issues. In the meantime, I’m going to close this support ticket out. Have a good one!

    Jordan

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Critical error’ is closed to new replies.