Support » Plugin: Jetpack Boost » Critical CSS – The rest doesn’t load

  • Resolved kkow

    (@kkow)


    The critical css generated is perfect, however everything below the fold has no styles applied at all. It looks like the css file has media=”print” applied, I’m assuming this is supposed to be removed after load somehow? Could this be due to also using autoptimize?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Nauris

    (@pyronaur)

    Hey @kkow! Can you share the URL where you’re trying out Boost?

    Do you have JavaScript enabled in your browser?

    Thread Starter kkow

    (@kkow)

    Hi @pyronaur,

    Is there a way to securely share a link so that it’s not public? After enabling all 3 options it appears that now all javascript has been removed from the page completely and never loads.

    Thread Starter kkow

    (@kkow)

    Also, yes JavaScript is enabled in the browser. Thank you!

    Thread Starter kkow

    (@kkow)

    From what I can tell, if I disable autoptimize then all stylesheets have an onload=this.media=all, however when autoptimize is added this onload event is not there.

    However, either way (activated or not) the defer js option seems to remove all js.

    Plugin Author thingalon

    (@thingalon)

    Hi @kkow

    You can send us links or images privately by emailing us at JetpackBoost@automattic.com. If you do email us more information, please include a link to this forum thread for context.

    Thank you for experimenting with Jetpack Boost, and giving us such a useful report. I’ve managed to reproduce the issue with Critical CSS, but have not had luck reproducing issues with deferred JavaScript yet.

    Based on my own experiments, it looks like Autoptimize’s “Aggregate CSS-files?” option is not compatible with Jetpack Boost. If that option is enabled, both plugins fight for control over how CSS is rendered and they end up in a tangle.

    We’ll continue experimenting with the defer js issues, and will hopefully be able to address some of these issues in a future release.

    Optimizing Matters

    (@optimizingmatters)

    For Autoptimize; try ticking the ‘inline & defer CSS’ option and untick ‘also aggregate inline CSS’, this will likely allow both to be used?

    frank (ao dev)

    Thread Starter kkow

    (@kkow)

    Hi @thingalon,

    Apologies for the delay here, after testing out @optimizingmatters solution I was able to get the critical CSS working. I do wish I was able to pull out the critical css and have the remaining be in one consolidated file, but I’m sure you guys are working through a lot as is. I appreciate the support and response from everyone!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Critical CSS – The rest doesn’t load’ is closed to new replies.