Support » Plugin: Backup & Migration - WPvivid Backup and Migration Plugin » critical bug without warnings

  • Be careful! I have a site on siteground(just mention because it is standard webhosting) I have the paid version and did a full backup of a site. My backup “successfully completed” the logs and details tab show the backup as a complete full backup that was successful. I tried to migrate my site(luckily didn’t need these backups, because I would be really in trouble then) but it would not restore. It turned out the zip files only have half of the files and the last zip file seamed to also be corrupt. I currently have a ticket open and WP vivid has finally acknowledged that I didn’t do anything wrong and there is an issue here. I just don’t know how you can trust your backup plugin if it can say in the logs completed successfully and then can’t use it to restore your site, not only that, restoring it completely broke the site. I will adjust my review if this bug is fixed, but this is a HUGE bug the plugin should report an error, I wonder how many people are using this plugin with broken backups they don’t even realize because they haven’t needed them?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support tonyrobins

    (@tonyrobins)

    Hello @nickfmc

    Sorry about the problem. We are going to try to locate and fix it soon and will keep you posted on any updates.

    And just a side note:

    From what we see so far, this is not a universal problem, as we are not able to reproduce the problem on our sites, and there are also thousands of users using our plugins to migrate/restore sites every day without any issues.

    All the best,

    Plugin Support tonyrobins

    (@tonyrobins)

    Hi there,

    Since we have not heard back from you for a while in the ticket, we are trying to post an update here. If you happen to see this message, please get back to us and we’d be more than happy to help further:

    1. After checking your backup and restoring it, we found that the backup is complete and the restore is successful. But there are PHP deprecation errors after restoration that we found later is because your custom theme(that was made 5 years ago) still uses some PHP snippets that have been deprecated.

    2. Based on the tests we have done together, we finally confirmed that it’s a download issue rather than an issue with the backup itself. Because the backup is complete and good when it is downloaded via FTP.

    3. The download issue is very likely related to your specific server configurations because it does not occur on our sites and we also have not received the same report from other users so far.

    4. We look forward to hearing back from you so we will be able to help further.

    All the best,

    WPvivid Support Team

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this review.