Support » Fixing WordPress » crippling permalinks bug!

  • Hi,
    After upgrading from 2.1 to 2.7, everything seemed fine, and i even decided to start using PHP5 to get Extended Live Archives working. The upgrade went well with no errors, and i could import all tags from UTW. The transition to a UTF8 database went well too.

    Today i noticed that even tough all is fine in the Admin section (the category and all post are there, i can edit them etc), i couldn’t get the posts in one category in the blog to show up. The category archives show, but when clicking on the posts’ links i will get to the homepage.

    Some poking around revealed this: for that one category, the posts will not show up, but the URL will be in the browser’s address bar and links (like the read more link in the homepage) will think i am in the post’s page.
    The category is called “ensinamentos”, and i can get the posts to display if i try mydomain/e/postname. If i substitute the letter “e” in the address by anything i will get to the post. If i substitute the letter “e” by “en” i will get a 404 (correctly). If i then substitute the letter “e” by “ens” i will get to the homepage.

    For all other categories, if i try mydomain/anything-at-all/postname, i will get to the posts!!!

    My htaccess is standart except for some 301 redirects (for old page management). I can post it here if needed, as well as the blog address for testing.

    I will be gratefull for any help on this.

Viewing 15 replies - 1 through 15 (of 19 total)
  • I just tried deactivating all plugins, and the problem is still here. I also tried going back to PHP4, but it didn’t help (i did it through htaccess itself with AddHandler).

    All help will be much appreciated!

    I’m not entirely clear what the issue is? The ensinamentos category doesn’t show at all? It works for me on a stock 2.7 build. What permalink setup have you got?

    Hi mrmist, thank you for your reply.

    If you go to my site (the homepage), you will see two posts: the one on the left is called “Penjin” and is in the “Ensinamentos” category. If you click on it, you will see that the URL in the browser changes to the post’s URL, but you still see the homepage. The one on the right is in another category and can be accessed normaly.

    If you go to the “Ensinamentos” archive, it shows allright, but clicking on any silgle post belonging to that category takes you to the homepage.

    As a troubleshooting measure one can try to go to:
    1) : this shows the post, surprisingly.
    2) : this shows a 404 correctly.
    3) : this takes you to the homepage.
    4) : shows the post, also very suprising.

    For all other categories, behavior is normal, except that simptom n. 4 is there too.

    The permalinks structure is: /%category%/%postname%/ which was working before the upgrade to 2.7. I have two other blogs in the same host, same setup, they work allright.

    Here is my htaccess:

    AddHandler php5-script .php
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    Redirect 301 /baixar/
    Redirect 301 /videos-e-livros/
    Redirect 301 /contato/
    RewriteCond %{HTTP_REFERER} !^$
    RewriteCond %{HTTP_REFERER} !^http://(www\.)?*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://(www\.)?*$ [NC]
    RewriteCond %{HTTP_REFERER} !^http://(www\.)?taijiquan.local/.*$ [NC]
    RewriteRule \.(gif|jpg|png|js|css|mp3)$ - [F]
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress

    It looks like the redirects just aren’t active or something.

    Have you tried setting permalinks to “default” and then back to your style?

    Hey mrmist,

    I hadn’t tried that – just did, but the problem remains. Looks like some redirection is working, just not working right.
    Do you know other troubleshooting measures?

    Thank you for your help.

    I also tried right now to create abrand-new htaccess file. I changed WP to default permalinks, trashed my htaccess, created a new one, and chaned WP to my permalinks cutom structure. The file was written on by WP, but the problem persists.

    I am out of ideas with this one I’m afraid.

    I’m gratefull for your trying!
    I’m out of ideas too. I know very little f code, but it kind of looks like a regex thing in WP’s rewrite engine. This is a wild guess, but why would i be able to access the posts by changing the category slug arbitrarily in the URL?

    I had a similar bizarre problem with my archives where only the Jan 09 Archives folder would display and the others would continually 403. Didn’t matter what I tried (and I tried what seemed like everything) it would still happen. Turned out there was a static folder called “2008” in the blog root with subfolders “10”, “11” etc. that would display instead and apparently interefere with the WP rewrites, serving a 403 Forbidden error when the directory listing request was denied. Just renamed that folder “2008-old” to test if that was it and voila, problem solved.

    I have no idea what that folder was doing there, but being new to WP and a little reckless I had been doing some dumb stuff and swapping plugins willy-nilly.

    Perhaps this is why you can get to the posts by inserting garbage – is there a static folder named “en” in the WordPress root that might be interfering if “en” is requested but not if something else is?

    Hi rrryan,
    Thank you for your help.
    I don’t have a “en” folder in the root. Anyway, i tried renaming a folder which name starts with an “e” to something else, but it didn’t work… I also deleted a cache folder in the root, but that didn’t work either.

    Does this happen with the default theme too?

    Yes, it does… just tried changing to default theme, the problem is still there.
    Thanks, mrmist!

    I can’t really understand this one. Unfortuantely to be able to log it as a bug it needs to be reproducable, otherwise it will be difficult to fix. And I’ve not been able to reproduce it, either.

    Well, it is online anyway, live at my website! I am willing to keep it there (and not change the category name to something else, for example) so it can be verified…

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘crippling permalinks bug!’ is closed to new replies.