Support » Plugin: MyMail SendGrid Integration » credentials are WRONG if Sendgrid password has special characters

  • Resolved haleeben

    (@haleeben)


    Hi

    I get the “credentials are WRONG” error message if my Sendgrid password has special characters ( $, %, ^ , & ). If I change my Sendgrid password to something without the special characters then MyMail accepts the credentials.

    Please change the password check to allow special characters in the password.

    Thanks

    https://wordpress.org/plugins/mymail-sendgrid-integration/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author revaxarts

    (@revaxarts)

    Hi!

    Just tested with a password starting with “$^” without problems.

    Can you send mails with this password?

    haleeben

    (@haleeben)

    I just checked and mail sends ok, but still have the Wrong credentials error.

    Also, I have the notice “Please make sure your SendGrid Account “preserve headers” otherwise MyMail is not able to handle bounces”.

    I have looked all through the Sendgrid setting and can’t find where to set preserve headers, can you point me in the right direction.

    Thanks

    Plugin Author revaxarts

    (@revaxarts)

    Hi!

    Maybe it’s not related to the plugin rather how your WP sends the data. I think if you able to send mails you’re fine.

    If I should investigate please open a ticket here: https://help.revaxarts.com/contact

    Preserve Headers in SendGrid must be requested. Check this:

    How to handle bounces with SendGrid?

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘credentials are WRONG if Sendgrid password has special characters’ is closed to new replies.