Support » Plugin: WooCommerce » Creating tax rates tables in woo commerce not working

  • when I tried to create or insert the row of tax rates after filling details like country code etc then save button but still showing No matching tax rates found. please help me if anyone can

    • This topic was modified 2 months, 1 week ago by roshantak44.
Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hi @roshantak44,

    I’ve performed some cross-testing for us today on several of my sites which have the latest versions of WordPress, WooCommerce and our free Storefront theme as the only enabled software. When doing so I’ve not been able to replicate the behaviour which you describe with WooCommerce not saving tax rates.

    This indicates that something on your site other than our WooCommerce plugin is having a negative effect and causing this behaviour which you are experiencing. Usually, isolated behaviour like what you describe and which has not displayed during our cross-testing can be related to code with another plugin or a theme which is causing a potential conflict of some kind.

    I’d suggest carrying out a conflict test in your site to try and locate the culprit. This document below offer guidance on how to conflict test on a WordPress installation.

    https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    If you haven’t carried out this type of testing on your site as yet it’s what we would recommend.

    I did these all tests nothing happen, in woocommerce ta rates whenever I create table by insert row and fill details then save but no new index is creating help!!!!!!!!

    Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hi @roshantak44,

    What you describe is not something I can personally replicate on any of my test installations of WooCommerce with tax rates that are entered being stored and displayed. It’s also not behaviour which I’m finding any other users reporting when using v4.2.0 of WooCommerce.

    Image Link: https://cloudup.com/cJcY64fJgnu

    What you’re experiencing currently seems isolated to only your WordPress installation. It’s not something which is directly related to the WooCommerce plugin itself on this occasion otherwise all installations and users would also be reporting the same behaviour which is not the case.

    I’d suggest checking the TAX page of WooCommerce using a browser console to see if you can spot any JavaScript or other errors.

    https://developers.google.com/web/tools/chrome-devtools/javascript

    I hope this helps.

    Hi @stuartduff,
    We have the same issue on one of our sites, were looking into it as I type.

    woocommerce_tax_rates
    woocommerce_tax_rate_locations
    both are empty, but settings are set on WC panel.

    roshantak44

    (@roshantak44)

    @themedutch So how can I solve this now??

    Themedutch

    (@themedutch)

    @roshantak44,
    We have to delete all tax WooCommerce > Status > Tools > Delete WooCommerce Tax rates. and I deactivated Woo-commerce and activated iT again. and added the new tax rates back..

    Plugin Support Stuart Duff

    (@stuartduff)

    Automattic Happiness Engineer

    Hey @themedutch,

    That is strange and not something I’m personally experiencing with v4.2.0 of WooCommerce on any of my test installs which I’ve compared for us.

    Are you and @roshantak44 both using v4.2.0?

    Thanks

    Themedutch

    (@themedutch)

    Weird huh Stuart, well not sure what caused it yet. But the above worked so clients are happy again.

    Were running since 2 hours on 4.2, previous version had the same issue.

    roshantak44

    (@roshantak44)

    @themedutch I tried your way but nothing happened what I should do now??

    Themedutch

    (@themedutch)

    @roshantak44 sorry to hear that, it worked for us so I did not research any further.

    alistairgd

    (@alistairgd)

    Same issue here.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.