Support » Fixing WordPress » Creating or updating posts generates a comment

  • Resolved lucydeetz

    (@lucydeetz)


    Hi everyone,
    As per title, whenever I update or create a post some very odd comments show up for approval on my WP dashboard. These comments are always structured as follows:

    Name: [Post title]
    Website: [Post URL]
    IP: xxx.xx.xxx.xx
    [The comment itself is just a collection of random words from the post content.]
    In response to: [Random post on the website, not the one that’s been updated]
    Submitted on: [Date of update]

    It’s been like this since I started publishing content on my website, but I’ve been adding new articles every day and the problem is getting worse. There’s a specific article that I need to update constantly and that generates a comment each and every time I update it.
    I tried disabling comments, but that didn’t help as I still see that little orange icon telling me there’s a random comment waiting for approval. If don’t publish or make changes to any articles, nothing strange happens.
    I have no idea what could be causing this and I can’t find absolutely nothing about such a problem on Google. Any suggestions?
    Thanks!

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • That’s a standard feature of WordPress (and most blogging software) called “pingback”: a type of comment that’s created automagically when you link to another blog post where pingbacks are enabled.

    These “pinbacks” can come from links to posts on your own blog (aka self-ping), or even links to external sites that support pingback.

    So, this “self-ping” is happening because you linked to the said “random post” in the post, and pingbacks are enabled by default on all WordPress sites.

    Please see the article below for various options to disable pingbacks for individual blog posts or globally.

    https://www.wpbeginner.com/wp-tutorials/how-disable-self-pingbacks-in-wordpress/

    Good luck!

    Thread Starter lucydeetz

    (@lucydeetz)

    Disabling the pingback option in the settings did the trick. Thank you so much!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Creating or updating posts generates a comment’ is closed to new replies.