Support » Plugin: Custom Fields for Gutenberg » Creating New Page, Custom area not viewable…

  • Resolved Kim White

    (@kimwhite)


    More an observation, bug perhaps?
    When I FIRST create the page I do not see the “Custom Field” area.
    However, after saving it (Draft or Publish), navigating away from the page, then coming back, the area did show up.

    Otherwise, very grateful for this plugin.

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Jeff Starr

    (@specialk)

    Yeah that sounds like a bug. I will investigate and try to resolve for the next plugin update. Thank you for reporting this, Kim.

    Plugin Author Jeff Starr

    (@specialk)

    Just to follow up with this. Turns out not a bug. It’s actually a feature. There is a line that checks if the current post has any meta data attached:

    if (!has_meta($post->ID)) return;

    So the custom fields are displayed only when the post actually has some attached meta. Because posts have no meta data when they are first created, the empty custom fields panel is not displayed. Otherwise just displaying an empty panel that says “Custom Fields” and that’s it looks kinda weird.

    I understand your argument. But what if you first set up a page/post and like to add a custom-field later? Depending from how you utilize custom-fields, this can happen very often (happens to me all the time). So it is quite cumbersome if you first have to delete the whole post/page and set it up again, insert all content again etc. – just because you want to add a custom-field.
    This Plugin is a great help for me, so I really would be grateful if the custom field bar is always visible or the hiding of the field would be optional in the settings.

    Plugin Author Jeff Starr

    (@specialk)

    You make a good point, I will take a closer look at this during the next plugin update. Will try to implement the best possible solution going forward. Thank you for your feedback.

    Plugin Author Jeff Starr

    (@specialk)

    Just to follow up, I decided to disable the check for existing post meta. The latest version (1.4) of the plugin always should load the Custom Fields meta box for all posts. Version 1.4 should be available within an hour or so, please let me know if you encounter any further issues. Thank you for reporting, Kim.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Creating New Page, Custom area not viewable…’ is closed to new replies.