WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Creating, Editing or Deleting Pages Trashes Site

[Resolved] Creating, Editing or Deleting Pages Trashes Site

  • I am having an odd problem and wondering if anyone else has seen anything like this… using wp 2.3.1

    Whenever I create a new page, edit an existing page or try to delete a page from the wp admin, it trashes my site… by trashing the site, I mean that only a blank, white page comes up for any page/post on the site… simply restoring the database brings the site back…

    It is also worth mentioning that I have none of these issues with posts. I can create/edit/delete those to my hearts content.

    I have checked/analyzed/repaired/optimized the database with no issues found…

    I have begun to suspect some sort of issue with permalinks/rewrite rules since pages deal directly with those and cause modifications…

    Going to the wp options – permalinks page also causes the same effect to my site without evening doing anything… that page wont even come up as it too comes up a blank, white page…

    When I try to create the page, the database entries in wp_posts and wp_postmeta are created but dont look finished. The dates in the wp_post entry for example will be all zeros…

    I looked at the .htaccess file and do not see any issues with it either… I have gone through the database and do not see any odd entries, but its a big database…

    Looking at the rewrite rules in the wp_options table is hard because its 35,000 characters long…

    I have also re-uploaded a WordPress installation to make sure I didnt have some corrupt files…

    Any thoughts? Thanks…

Viewing 3 replies - 1 through 3 (of 3 total)
  • Also might be worth mentioning that I blew away the rewrite_rules entry in wp_options thinking it would just get rebuilt by WP…

    This also caused the blank, white page…

    Just adding that the page_uris entry in the wp_options table looks correct…

    this is just mystifying me…

    after digging a bit further into my .htaccess file, discovered an old gallery2 rewrite rule for the g2 admin pages in there…

    Further research showed that the gallery2 stuff wasnt using my url rewrite rules I had defined… very odd…

    digging further into the gallery2 stuff showed that the rewrite module had actually deactivated itself because it thought it was an out of date module…

    downloaded the latest update, installed it and updated the rewrite rules (including getting rid of the bad g2admin rewrite rule)…

    now, everything seems to be working… no clue how these are related, especially since I hadnt touched the g2 stuff in many months…

    oh well, hopefully it stays working…

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘[Resolved] Creating, Editing or Deleting Pages Trashes Site’ is closed to new replies.
Skip to toolbar