Support » Fixing WordPress » Creating default object from empty value of line 639 wp-admin/includes/post.php

  • pinkdigital

    (@pinkdigital)


    Site was automatically upgraded to the latest version 4.5.3. Now every new post has this error across the top and the content box does not appear.

    Creating default object from empty value of line 639 wp-admin/includes/post.php

    Has anybody experienced this error before?

Viewing 15 replies - 1 through 15 (of 16 total)
  • Moderator Matthew

    (@kidsguide)

    Volunteer Moderator

    Try deactivating all plugins. If that resolves the issue, reactivate each one individually until you find the cause.

    If that does not resolve the issue, try switching to the default theme for your version of WordPress to rule-out a theme-specific issue (theme functions can interfere like plugins).

    If neither of those work try downloading WordPress again, access your server via SFTP or FTP, or a file manager in your hosting account’s control panel, and delete then replace your copies of everything except the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings.

    Some uploaders tend to be unreliable when overwriting files, so don’t forget to delete the original files before replacing them.

    pinkdigital

    (@pinkdigital)

    I have done everything that you suggest and nothing has resolved the problem.

    Moderator Matthew

    (@kidsguide)

    Volunteer Moderator

    What version of WordPress were you using before it automatically updated to WordPress 4.5.3?

    pinkdigital

    (@pinkdigital)

    4.5.2

    I am getting exact same problem in same line “Creating default object from empty value of line 639 wp-admin/includes/post.php”. IN this line this code is present:
    $post->post_content = apply_filters( 'default_content', $post_content, $post );
    Deactivate plugin and switching to default theme won’t help. I can’t add new pages because of it!

    The error stats appearing when I import database and overwrite the prev. database. all files of database was from my prev. wordpress version of database.

    @pinkdigital Have you got this error in exactly same way like In my case it accure in importing database and on login i have been asked to update database and I did. so error starts appearing.

    Is this what happened in your case also? Any suggestion regarding this.

    Ok some progress in my problem. Problem accure when I overwrite all those table that wordpress auto create on installation. I overwrite bcos I need to store all data from my previous domain.

    So right now I am trying to import data not through database but instead database I m trying to import via dashboard -> tools -> import. Its worked really fine But only one issue I m facing is that I have uploaded my prev. wp_content folder (by deleting new) to my new setup so that I can get my images, theme and plugin.

    Plugin and theme I got form wp_content folder But somehow I am not getting any images in media library! Although all images is present in upload folder but why its not showing in media library!!???

    I think you should check your disk. I think it’s full

    ltd300

    (@ltd300)

    Here it is my solution, it works for me.

    Go to your phpMyAdmin -> wp_posts -> Structure then got to edit (change) ID and check the A I (auto increment) -> Save.

    • This reply was modified 5 months ago by  ltd300.
    ayyazahmad

    (@ayyazahmad)

    While executing following solution:
    Go to your phpMyAdmin -> wp_posts -> Structure then got to edit (change) ID and check the A I (auto increment) -> Save.

    Following error apears:
    Query error #1075 – Incorrect table definition; there can be only one auto column and it must be defined as a key

    Same issue for me 🙁

    I seem to have fixed it by running a repair on my wo database across all tables from within myphp. Hope that helps others.

    • This reply was modified 4 months, 1 week ago by  mikehampton.

    @ltd300 solution worked for me.

    dankfresh

    (@dankfresh)

    was definitely a size issue for me. My MySQL database exceeded its disk space. I was using 1and1 shared hosting (which originally had 100MB sizing), but creating new databases allowed 1024MB. So I created a new database, exported my tables from the old database, imported them into the newly created database, and changed my wp-config file. Was fixed right away.

    nguyenduyphong88

    (@nguyenduyphong88)

    adage

    (@adage)

    Thank you @ldt300 !

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.