Support » Fixing WordPress » creating a network/multi-site in 3.1.2 – not working!

  • Hello – I hope that someone can help me with this please.. it is quite a lenghthy description which hopefully has a simple solution!

    I am trying to create a network/multi-site so that I can have two sites/blog’s. I am creating my WP site locally on a Mac, using MAMP. Have followed instructions to enable the Network on the WP Dashboard under Tools – have tried making suggested changes to the Wp-config.php file – changes suggseted are as below:
    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, false );
    $base = ‘/’;
    define( ‘DOMAIN_CURRENT_SITE’, ‘localhost:80’ );
    define( ‘PATH_CURRENT_SITE’, ‘/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    Incidentally, in the file already is a line saying:
    define( ‘WP_ALLOW_MULTISITE’, true );

    I have tried several times to add the suggested text to the WP-config.php file and to then log-in again, as instructed – but each time I do I get an error page telling me I cannot log-in. When I remove the text from the config page I can log-in again – but no sign of the Network Admin link supposed to be now on my dashboard. However when I go to modify/look at Network via Tools again there is a message saying ‘An existing WP Network was detected’ – so evidently I’ve gone some way to creating it.. just not all the way..!

    Also, as instructed in the Enabling instructions under Create a Network/Tools – I’ve tried to modify .htaccess file – or as I later read in WordPress help page instructions, create one. As I couldn’t find and .htaccess file in the HTDOCS – despite looking for system files etc. So I have created one with the relevant text in it. Though each time I search for it again I cannot view it…

    I am so close to having a network up and running, or at least I thought I was! Any help would be much appreciated on this, thank you. When I search for the .htaccess file a seletion of other files comes up, but never that one, despite enabling system files in the search.

    Many thanks in advance.

Viewing 4 replies - 1 through 4 (of 4 total)
  • N.B As an update I have just tried to view my current blog that I’ve already started to work on – though it isn’t on a host server yet – and I am getting an error message saying it is ‘not found on the server’
    I’m guessing that in starting to set up the Network (and giving it a name..?) that this has somehow altered the URL/permalinks for my current blogs/future network??

    Oh dear… a bit of a tangled up mess it seems, hopefully a kindly soul will be able to help me untangle it.. please!

    I am working on doing a multisite install and when I went to edit the .htaccess file using exactly what was supplied by Worpdress when creating the network, my site no longer worked. When I reverted back to the old .htaccess file, the site was back up. It appears that the network was created but the changes weren’t really made to the .htaccess file. I’m wondering if the sub-domain sites won’t work because of this. Hoping I can get some thoughts on this.

    @sparklogix – sorry, my situation is still unresolved – in the end I’ve resinstalled Mamp and WordPresss and am starting from scratch….
    however, I’d like to look into what you have flagged up as a problem – it may of been what caused my site to no longer work too..
    I cannot view the .httaccess file on my Mac – though I’ve created and saved it in Textedit. Can you cast light on how to view a .hattaccess file please?


    The way I access my .htaccess file is via FTP. I have to go into the options and select “View hidden files” and then I’m able to see it. HTH

    I tried setting up some subdomain sites in the multisite install last night and everything worked just fine.

    I did wind up reverting back to the .htaccess info that I was given during the multisite setup. This is what my .htaccess file looks like:

    # BEGIN WordPress
    <IFModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    #uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    # END WordPress
Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘creating a network/multi-site in 3.1.2 – not working!’ is closed to new replies.