Support » Plugin: DsgnWrks Instagram Importer » Created User & Options disappear on saving

  • I’ve just added this plugin to my site. Went to the settings, clicked on Create new user. I linked it to my instagram account and then got the options page up. Set all of the options for where/how to post it etc. I then clicked Save and now all I get is the option to add a new user and general options.

    Looking in the options table in the DB I can see myself in a serialised array under dsgnwrks_insta_users and under dsgnwrks_insta_options I just see the generic options.

    I can see in the code that it looks to see if any users are set up but then it stops loading them at the check

    
    if ( ! $this->user_option( 'full_username' ) ) {
        // something's wrong, skip this user
        $this->debugsend( '91' );
        continue;
    }
    

    I’m not sure where debugsend goes or what it does but that’s the point where it’s falling over. So I then can’t edit my own options page, I can’t see the options saved in the options table either.

    Any ideas what’s happening or going wrong?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author Justin Sternberg

    (@jtsternberg)

    Hmm that seems like an odd glitch, and i’m not sure what went wrong. I know it’s a pain, but since you have access to the DB, can you delete those two options and try the setup again?

    Thanks Justin, I did delete them, disabled and re-enabled the plugin and it’s still done it. Everything looks fine until I save the settings and then it just doesn’t show my added user, but it knows its there as the get started changes plus as mentioned, I can see my Instagram user in the option array, but no saved settings (not sure if they would be in either of those options of a third?)

    Plugin Author Justin Sternberg

    (@jtsternberg)

    If you open your browser’s javascript console, do you see any errors when you’re doing these settings updates?

    Hi Justin, there’s no errors at all showing. I’ve just removed the two option records and tried again, no JS errors showing up. Here’s a screenshot of what I get once I hit save

    http://prntscr.com/ez6ym1

    I’ll try this on another WP site once the kids are in bed and see if it happens there for me, and I’ll also try reverting my theme back to a standard one plus disable plugins in case something is conflicting with it. Will let you know.

    Thanks

    Plugin Author Justin Sternberg

    (@jtsternberg)

    That is frustrating. Thank you for doing the legwork, and please let me know what you find.

    So, after a lot of echoing out in various parts of the plugin files I’ve discovered that it’s down to my host’s DB not liking the arrow in the post content field (I didn’t change this from the default)

    View in Instagram ⇒

    I set the plugin up on my local install of WP and it was fine. I copied the options field over via phpMyAdmin and it was instantly complaining about an encoded character. Once I removed the arrow and altered the string count it worked fine. I can only assume it was this that caused the settings not to save in the first place either.

    I’m guessing this is an encoding setting with my DB or server? It’s not major, I can live without an arrow 🙂

    Thanks for your help, I can have a little play with this now 🙂

    Plugin Author Justin Sternberg

    (@jtsternberg)

    Wow, that’s super weird. I have never heard of that happening. Thanks again for taking the time to debug and report back. I’ll have to add this to the readme somewhere. (or just take the arrow out of the default value setup)

    FYI, I’m seeing the same issue, but I have no were near the knowledge of sarah.
    I have the save when after saving the settings when adding a user.

    Sarah were you able to change something to get it to work with you DB?

    Thanks,jb

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Created User & Options disappear on saving’ is closed to new replies.