WordPress.org

Forums

created a theme from scratch - how to install plugin (6 posts)

  1. TreeParlor
    Member
    Posted 3 years ago #

    I've created my very first wp theme from scratch. I'd like to make use of the plugins available.

    My website is a standard site - no blog. I don't need much functionality and so I haven't the need for a functions.php. Or do I?

    If I want to take advantage of plugins. What do I need to set up first?

  2. alchymyth
    Forum Moderator
    Posted 3 years ago #

    plugin management is by default under
    dashboard - plugins;

    to run plugins, you don't need a functions.php in your theme.

    for details, check the instructions of the individual plugin.

  3. TreeParlor
    Member
    Posted 3 years ago #

    Great! Glad to hear I don't need the functions.php

    I'm trying to work with "promotions slider". I have followed the video tutorial. I get this error

    "
    Notice: Undefined index: _promo_slider_disable_links in /home2/treeparl/public_html/testing/wp-content/plugins/promotion-slider/index.php on line 275

    Notice: Undefined index: _promo_slider_show_ad_code in /home2/treeparl/public_html/testing/wp-content/plugins/promotion-slider/index.php on line 275

    Warning: Cannot modify header information - headers already sent by (output started at /home2/treeparl/public_html/testing/wp-content/plugins/promotion-slider/index.php:275) in /home2/treeparl/public_html/testing/wp-includes/pluggable.php on line 866

    "

    I've uninstalled and installed the plugin a few times, but still get the error. Therefore I figured I needed something I am missing.

  4. alchymyth
    Forum Moderator
    Posted 3 years ago #

    plugins often use the wp_head() and/or wp_footer() hooks -

    do you have these in header.php and footer.php, resp. ?

    http://codex.wordpress.org/Function_Reference/wp_head

    http://codex.wordpress.org/Function_Reference/wp_footer

  5. TreeParlor
    Member
    Posted 3 years ago #

    Yep. Did that :)

  6. Micah Wood
    Member
    Posted 3 years ago #

    I take it these errors only occur when you are saving a promotion? These are due to an oversight on my part when no value is entered in the meta box fields. These are just notices, so setting WP_DEBUG to false in wp-config.php will hide the notices and make the site work properly. You never want to have WP_DEBUG active on a live site anyway.

Topic Closed

This topic has been closed to new replies.

About this Topic