Support » Plugin: BackWPup - WordPress Backup Plugin » Created a back up but cannot download

  • Resolved Maija Bundgaard

    (@maija-bundgaard)



    I have created a full backup using the plugin and when navigating to back ups this is now visible.

    However, when I click on download a small window opens, all white with only the text displaying “Please wait…”

    No download happens.

    How can I fix this?

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author duongcuong96

    (@duongcuong96)

    Hi @maija-bundgaard,
    Could you please try with another browser like Firefox, Chrome?
    Also, Please show me your server configuration by go to BackWPUp -> Settings -> Infomation -> and press “Get debug info”.
    Thanks!

    I was working from Chrome. I will try from Firefox.

    The info is as follows:

    WordPress version: 4.8.7
    BackWPup version: 3.6.0
    PHP version: 5.4.45 (64bit)
    MySQL version: 5.6.39-83.1
    cURL version: 7.19.7
    cURL SSL version: NSS/3.27.1
    WP-Cron url: https://govillascyprus.com/wp-cron.php
    Server self connect: Response Test O.K.
    Document root: /home3/maija/public_html
    Temp folder: /home3/maija/public_html/wp-content/uploads/backwpup-69a5d3-temp/
    Log folder: /home3/maija/public_html/wp-content/uploads/backwpup-69a5d3-logs/
    Server: Apache
    Operating System: Linux
    PHP SAPI: cgi-fcgi
    Current PHP user: maija
    Maximum execution time: 30 seconds
    BackWPup maximum script execution time: 30 seconds
    Alternative WP Cron: Off
    Disabled WP Cron: Off
    CHMOD Dir: 0755
    Server Time: 8:5
    Blog Time: 08:05
    Blog Timezone:
    Blog Time offset: 0 hours
    Blog language: en-GB
    MySQL Client encoding: utf8
    PHP Memory limit: 256M
    WP memory limit: 40M
    WP maximum memory limit: 256M
    Memory in use: 93.25 MB
    Disabled PHP Functions:: dl
    Loaded PHP Extensions:: Core, PDO, Phar, Reflection, SPL, SimpleXML, SourceGuardian, Zend Guard Loader, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dom, ereg, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, iconv, imagick, imap, intl, ionCube Loader, json, libxml, mbstring, mcrypt, mhash, mssql, mysql, mysqli, odbc, openssl, pcre, pdo_mysql, pdo_sqlite, posix, pspell, session, soap, sockets, sqlite3, standard, tidy, tokenizer, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

    Please let me know what to do?

    Plugin Author duongcuong96

    (@duongcuong96)

    Hi @maija-bundgaard
    Are you able to upgrade the PHP version to about 5.6 or better 7.2?
    Just contact your hoster and tell them about this then they will do it for you.
    If not possible for you, please replace class-destination-folder-downloader.php in your web root/wp-content/plugins/backwpup/inc/ with the one in here: https://gist.github.com/duongcuong96/d06a332dc2354aafa46b5be64db9dea1
    After that, please try download again πŸ™‚

    Plugin Author duongcuong96

    (@duongcuong96)

    @maija-bundgaard
    since we haven’t heard back from you, I’m going to mark it as resolved.
    If you’re still having problems, feel free to let us know ;),

    Btw, If you find BackWPUp is useful for you, we would really appreciate if you leave a positive review and rating.
    This would encourage us to develop new free features and provide free support πŸ˜€
    https://wordpress.org/support/plugin/backwpup/reviews/

    hennebe

    (@hennebe)

    I am having the exact same problem. Here is the quirk: The backup runs and downloads in my main domain liburiedalive.com, but in my subdomain cchspetshelter.liburiedalive.com it will only run the job (if I temporarily unprotect it)–but won’t let me download the backup.

    I called my hosting support and we did try updating the PHP to 7.0. No luck.

    Here is the info for the subdomain:
    WordPress version 4.9.8
    BackWPup version 3.6.0 Get pro.
    PHP version 5.4.45 (64bit)
    MySQL version 5.6.32-78.1
    cURL version 7.19.7
    cURL SSL version NSS/3.27.1
    WP-Cron url http://cchspetshelter.liburiedalive.com/wp-cron.php
    Server self connect Response Test O.K.
    Document root /home5/liburied/public_html/cchspetshelter
    Temp folder /home5/liburied/public_html/cchspetshelter/wp-content/uploads/backwpup-6fba11-temp/
    Log folder /home5/liburied/public_html/cchspetshelter/wp-content/uploads/backwpup-6fba11-logs/
    Server Apache
    Operating System Linux
    PHP SAPI cgi-fcgi
    Current PHP user liburied
    Maximum execution time 30 seconds
    BackWPup maximum script execution time 30 seconds
    Alternative WP Cron Off
    Disabled WP Cron Off
    CHMOD Dir 0755
    Server Time 4:45
    Blog Time 23:45
    Blog Timezone America/Chicago
    Blog Time offset -5 hours
    Blog language en-US
    MySQL Client encoding utf8
    PHP Memory limit 256M
    WP memory limit 40M
    WP maximum memory limit 256M
    Memory in use 51.75 MB
    Loaded PHP Extensions: Core, OAuth, PDO, PDO_ODBC, Phar, Reflection, SPL, SimpleXML, SourceGuardian, Zend Guard Loader, bcmath, bz2, calendar, cgi-fcgi, ctype, curl, date, dba, dom, enchant, ereg, exif, fileinfo, filter, ftp, gd, gettext, gmp, hash, http, iconv, imagick, imap, intl, ionCube Loader, json, ldap, libxml, magickwand, mailparse, mbstring, mcrypt, mhash, mysql, mysqli, oci8, odbc, openssl, pcntl, pcre, pdo_dblib, pdo_mysql, pdo_pgsql, pdo_sqlite, pgsql, posix, pspell, readline, recode, session, shmop, soap, sockets, sqlite3, standard, sysvmsg, sysvsem, sysvshm, tidy, tokenizer, uploadprogress, wddx, xml, xmlreader, xmlrpc, xmlwriter, xsl, zip, zlib

    • This reply was modified 3 months ago by  hennebe.
    abyjrc

    (@abyjrc)

    Hi
    I have PHP Version 5.6.37 (64bit)
    I have changed the class-destination-folder-downloader.php file with the one on your link https://gist.github.com/duongcuong96/d06a332dc2354aafa46b5be64db9dea1
    Still can’t donwload

    Please advice

    Plugin Author duongcuong96

    (@duongcuong96)

    Hi @hennebe
    @abyjrc

    Please try to clear your browser cache or change another browser, is that helps?

    abyjrc

    (@abyjrc)

    Thanks for your response.
    Cleared cache on Google Chrome, didn’t work
    Try to do it on Firefox, didn’t work either

    Only shows a with popup screen with message “Please wait”…

    hennebe

    (@hennebe)

    I tried in Chrome, Safari, and Firefox. Cleared cache. Same as abyjrc, didn’t work.

    This backup is on a password-protected subdomain of my main site. I had to temporarily remove the password-protection to get the backup to run (which it did), but the download won’t go either way. The main site had no problems.

    I had decided not to renew my domains/hosting this year, which is why I was backing up (in case I decided to put the sites back up). They expired on the 9th–so the delay in your response may have cost me my backup. I did get a version to upload to DropBox, but it is a different file format than the download that I did of the main site. A little disappointing, all around.

    Plugin Author duongcuong96

    (@duongcuong96)

    @hennebe
    Are you able to check your server log? Maybe something in there.
    Thanks!

    hello,
    i have the same problem.
    I use the bitnami wordpress package on windows 10. My browser is Chrome.
    Apache version : 2.4.37
    Php version : 7.1.23
    Apache Error logs :

    [Tue Nov 06 00:44:14.622918 2018] [php7:error] [pid 9568:tid 1316] [client ::1:52391] PHP Fatal error: Uncaught Error: Call to undefined function mime_content_type() in M:\\Bitnami\\wordpress-4.9.8-2\\apps\\wordpress\\htdocs\\wp-content\\plugins\\backwpup\\inc\\class-destinations.php:131\nStack trace:\n#0 M:\\Bitnami\\wordpress-4.9.8-2\\apps\\wordpress\\htdocs\\wp-content\\plugins\\backwpup\\inc\\class-page-backups.php(556): BackWPup_Destinations->file_download(‘1’, ‘M:/Bitnami/word…’, ‘2018-11-06_01-3…’)\n#1 M:\\Bitnami\\wordpress-4.9.8-2\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(286): BackWPup_Page_Backups::ajax_download_file(”)\n#2 M:\\Bitnami\\wordpress-4.9.8-2\\apps\\wordpress\\htdocs\\wp-includes\\class-wp-hook.php(310): WP_Hook->apply_filters(”, Array)\n#3 M:\\Bitnami\\wordpress-4.9.8-2\\apps\\wordpress\\htdocs\\wp-includes\\plugin.php(453): WP_Hook->do_action(Array)\n#4 M:\\Bitnami\\wordpress-4.9.8-2\\apps\\wordpress\\htdocs\\wp-admin\\admin-ajax.php(100): do_action(‘wp_ajax_downloa…’)\n#5 {main}\n thrown in M:\\Bitnami\\wordpress-4.9.8-2\\apps\\wordpress\\htdocs\\wp-content\\plugins\\backwpup\\inc\\class-destinations.php on line 131, referer: http://localhost/wordpress/wp-admin/admin.php?page=backwpupbackups

    update :
    i have found the solution :
    in my php.ini, i have enabled the fileinfo extension :

    extension=php_fileinfo.dll
    

    More infos :

    You must have the mime_magic extension on. Check your php.ini and look in phpinfo(). By the way this function has been deprecated as the PECL extension Fileinfo provides the same functionality (and more) in a much cleaner way.

    Windows users must include the bundled php_fileinfo.dll DLL file in php.ini to enable this extension.

    The libmagic library is bundled with PHP, but includes PHP specific changes. A patch against libmagic named libmagic.patch is maintained and may be found within the PHP fileinfo extensions source.

    • This reply was modified 1 week, 1 day ago by  jurassicpork.
    • This reply was modified 1 week, 1 day ago by  jurassicpork.
    Plugin Author duongcuong96

    (@duongcuong96)

    Hi @jurassicpork
    Thank you for the detailed answer so after enabled extension=php_fileinfo.dll, the error is gone and you can download the file?
    Thank you very much!

    yes the error is gone, now i can download the backup files.

    Plugin Author duongcuong96

    (@duongcuong96)

    @jurassicpork
    Thank you very much for the report about this!
    I will inform other users have the same issue as you about this solution πŸ˜€

    Pat K

    (@blackcapdesign)

    Thanks jurassicpork! This for worked for me as well. For anyone with WHM access, the FILEINFO extension for PHP can be installed via EasyApache (easier than doing this on a per-account basis). As soon as I installed FILEINFO, the unending ‘please wait’ popup message flashed only momentarily before the file was downloaded successfully.

    Hopefully the developers are made aware of this…this has been a huge problem for many people for months (since v3.4.5). It would be nice if there was a fallback that allowed this plugin to work for those who do not have or cannot have the FILEINFO extension installed on their hosting server.

Viewing 15 replies - 1 through 15 (of 24 total)
  • You must be logged in to reply to this topic.