Support » Plugin: WooCommerce PayPal Payments » create_order_error

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support Inpsyde Niklas

    (@niklasinpsyde)

    Hi @rollybueno,

    To learn more about these orders, we would be interested in your plugin log files. These log files are only written when “Logging” is enabled in the plugin settings.
    If enabled, then every transaction will create a log entry that can be accessed from here:
    WooCommerce > Status > Logs > select “woocommerce-paypal-payments-[…]” in the dropdown and click on view. 
    In case “Logging” was not yet enabled, could you please enable it and then try again to reproduce the error message so it is stored in the logs?

    Also, if you can reproduce the issue, then you may want to perform a full conflict test to rule out eventual issues with the theme or a different plugin. We recommend temporarily activating the default theme Storefront and disabling all other plugins except for WooCommerce and PayPal Payments to see if the behavior persists.
    Thanks!

    Kind regards,
    Niklas

    Thread Starter rollybueno

    (@rollybueno)

    Hey @niklasinpsyde,

    Thanks for your reply. This is the log content from last night: https://gist.github.com/rollybueno/7bd30ed168537b6f9a7ceabc66f37385

    Additional info that may be useful for you:

    1. When we encountered this issue, there were no orders made on WC. Error just visible on console log in Chrome/FF/Edge
    2. Most of the errors are broken JSON response, which may look like coming from PP itself?

    Thanks!

    • This reply was modified 5 months ago by rollybueno.
    Thomas Anderson

    (@celsiusanderson)

    Does this happen for the new customers? For me, the plugin does not cause any problem creating orders when it’s a new customer. It makes a problem returning customers from any country try to place an order with PayPal.

    Thread Starter rollybueno

    (@rollybueno)

    Hey @celsiusanderson, in our case it’s random but high probability if the customer is coming from UK or using mobile

    Hey there,

    as a followup of @rollybueno update, here’s another set of errors, that’s from the console when you click on the pay with paypal button – https://gist.github.com/metodiew/1da6fcdb2fa57536bc8f469fbcedfd84

    The project and the setup is the same:
    WooCommerce Version 6.21
    WooCommerce PayPal Payments version 1.7.0

    Plugin Support Inpsyde Niklas

    (@niklasinpsyde)

    Hi @rollybueno & @metodiew,

    The WooCommerce order is only created after the PayPal order. So when the popup window doesn’t open properly, then there will be no WooCommerce order.
    The console error looks like it could be coming from the PayPal SDK but we’d need to perform some more tests to better judge it. Do you have a staging site where the plugin could be activated without interfering with the live site?

    Since there’s a webhook error in the provided log, I suggest making sure the webhooks are registered correctly, from the “Webhooks Status” dashboard.
    On that page, click on Resubscribe and afterward Simulate to verify that the webhooks are received.
    If it takes a while and displays an error after trying to simulate, then we would be interested in another copy of your latest log file.
    Thanks!

    If you can reproduce the issue somewhat reliably, then I would suggest performing a full conflict test to rule out eventual issues with the theme or a different plugin. A staging site with the same issue can be handy for this. We recommend temporarily activating the default theme Storefront and disabling all other plugins except for WooCommerce and PayPal Payments to see if the behavior persists.

    Read more about plugin and theme conflicts in the WooCommerce Self-Service Guide.

    @celsiusanderson Please create a separate thread as I don’t think you are encountering the same issue. Thanks!

    Kind regards,
    Niklas

    Plugin Support Joost van de Vijver

    (@joostvandevijver)

    hello,

    we will mark this thread as resolved since we have not had any activity on it for over a month. Don’t hesitate to open a new thread if you still need our support on this or any other issue.

    Kind regards,
    Joost

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.