Support » Plugin: WCAG 2.0 form fields for Gravity Forms » create_function() is deprecated in PHP 7.2

  • PHP 7.2 has marked create_function() as deprecated, so this plugin will start throwing a warning if you update your PHP version. It’ll look something like this:

    Deprecated: Function create_function() is deprecated in [path to your wp-content directory]/plugins/gravity-forms-wcag-20-form-fields/gravity_forms_wcag20_form_fields_plugin.php on line 61

    Until the plugin is updated, change line 61 to:

    add_filter( 'gform_tabindex', '__return_false' ); //disable tab-index

    • This topic was modified 1 year, 3 months ago by  Doug Sheppard.
Viewing 2 replies - 1 through 2 (of 2 total)
  • I have the same problem after updating to PHP 7.2

    Deprecated: Function create_function() is deprecated in ..\plugins\gravity-forms-wcag-20-form-fields\gravity_forms_wcag20_form_fields_plugin.php on line 61

    When using add_filter( 'gform_tabindex', '__return_false' ); //disable tab-index (thanx Doug) it doesn’t show the error and seems to work fine.

    Clifford Paulick

    (@cliffpaulick)

    Confirmed that Doug’s solution worked. I wish this plugin was on GitHub to submit a pull request.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘create_function() is deprecated in PHP 7.2’ is closed to new replies.