Support » Plugin: WooCommerce Services » Create Shipping Label button won’t load

  • Resolved bignuggetfarm

    (@bignuggetfarm)


    When I open a customer order, about 90% of the time the “create shipping label” button will not load. It just continues to spin the colors through the button, like it’s trying to load. This will go on indefinitely sometimes, but I typically have to refresh the page (occasionally more than once) for it to completely load. Everything else on the page is loading correctly, so it’s not my internet or computer. This started happening more and more often over the last month or so. Please help me fix this time consuming issue.

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Nicola Mustone

    (@nicolamustone)

    Automattic Happiness Engineer

    Hello there,
    This kind of problem is usually caused by either a conflict with your theme or with another plugin.
     
    The best way to determine this is to:

    • Temporarily switch your theme to Storefront
    • Disable all plugins except for WooCommerce
    • Repeat the action that is causing the problem

    If you’re not seeing the same problem after completing the conflict test, then you know the problem was with the plugins and/or theme you deactivated. To figure out which plugin is causing the problem, reactivate your other plugins one by one, testing after each, until you find the one causing conflict. You can find a more detailed explanation on how to do a conflict test here.

    I do have this message at the top of my screen:
    Your theme (Big Nugget Farm) contains outdated copies of some WooCommerce template files. These files may need updating to ensure they are compatible with the current version of WooCommerce.
    However, I have no idea how to fix this nor do I have money right now to pay someone to do it. Is it safe to assume this is causing the issue? The theme I believe I’m using was custom created by a person I can no longer use. I have no desire to redesign my whole site.
    I’m not a coder or programmer, but won’t disabling all the plugins cause major issues on my website? I don’t know if there’s a way to put it into maintenance mode or similar so I don’t cause any issues for customers.

    Plugin Support Fernando

    (@fhaps)

    Automattic Happiness Engineer

    @bignuggetfarm It’s hard to know whether this is indeed what is causing the issue, following the steps recommended above would be the best way to find out.

    We recommend that those steps are taken on a staging site, which is a clone of your live site that you can modify without risking making any permanent damage to your live site. You can create it using a plugin like WP-Staging: https://wordpress.org/plugins/wp-staging/

    Whether the theme is what’s causing this problem or not, you might consider looking into a new theme soon. It’s not a good idea to run a WooCommerce store (or any WordPress website, really), on outdated software.

    Plugin Support Fernando

    (@fhaps)

    Automattic Happiness Engineer

    We haven’t heard back from you in a while, so I’m going to mark this as resolved – if you have any further questions, you can start a new thread.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.