Support » Plugin: Forminator - Contact Form, Payment Form & Custom Form Builder » Create post doesn’t fill up the custom fields in the post.

  • Resolved markovetski

    (@markovetski)


    Hi,

    I am trying to use the Forminator create post template with Jet engine custom field (taxonomies that are operating as categories) but it seems that they are not filling into the post.

    Please see the following photos and the form code:
    https://snipboard.io/42xONu.jpg
    https://snipboard.io/xz0uEe.jpg
    https://snipboard.io/vwxt60.jpg

    The code:
    {"type":"form","data":{"fields":[{"id":"postdata-1","element_id":"postdata-1","form_id":"wrapper-1511347711918-1669","type":"postdata","cols":"12","data_status":"publish","post_title_label":"Post Title","post_content_label":"Post Content","post_excerpt_label":"Post Excerpt","post_image_label":"Featured Image","category_label":"Category","post_tag_label":"Tags","select_author":1,"category_multiple":"0","post_tag_multiple":"0","post_type":"gbo","post_title":true,"post_content":false,"category":true,"post_image":true,"options":[],"post_excerpt":true,"post_tag":true,"post_custom_fields":true,"country-flag":true,"company_role":true,"industry":true,"wpn_customer_type":true,"subject":true,"marketing_channel":true,"continent":true,"sort":true,"value":"%my_value_1%","wrapper_id":"wrapper-1511347711918-1669","conditions":[]}],"settings":{"pagination-header":"nav","paginationData":{"pagination-header-design":"show","pagination-header":"nav"},"formName":"GBO autopost","version":"1.10.2","form-border-style":"none","form-padding":"","form-border":"","fields-style":"open","validation":"on_submit","form-style":"default","enable-ajax":"true","autoclose":"true","submission-indicator":"show","indicator-label":"Submitting...","submission-behaviour":"behaviour-thankyou","thankyou-message":"Thank you for contacting us, we will be in touch shortly.","submitData":{"custom-submit-text":"Create Post","custom-invalid-form-message":"Error: Your form is not valid, please fix the errors!"},"validation-inline":"1","form-expire":"no_expire","form-padding-top":"0","form-padding-right":"0","form-padding-bottom":"0","form-padding-left":"0","form-border-width":"0","form-border-radius":"0","cform-label-font-family":"Roboto","cform-label-custom-family":"","cform-label-font-size":"12","cform-label-font-weight":"bold","cform-title-font-family":"Roboto","cform-title-custom-family":"","cform-title-font-size":"45","cform-title-font-weight":"normal","cform-title-text-align":"left","cform-subtitle-font-family":"Roboto","cform-subtitle-custom-font":"","cform-subtitle-font-size":"18","cform-subtitle-font-weight":"normal","cform-subtitle-text-align":"left","cform-input-font-family":"Roboto","cform-input-custom-font":"","cform-input-font-size":"16","cform-input-font-weight":"normal","cform-radio-font-family":"Roboto","cform-radio-custom-font":"","cform-radio-font-size":"14","cform-radio-font-weight":"normal","cform-select-font-family":"Roboto","cform-select-custom-family":"","cform-select-font-size":"16","cform-select-font-weight":"normal","cform-multiselect-font-family":"Roboto","cform-multiselect-custom-font":"","cform-multiselect-font-size":"16","cform-multiselect-font-weight":"normal","cform-dropdown-font-family":"Roboto","cform-dropdown-custom-font":"","cform-dropdown-font-size":"16","cform-dropdown-font-weight":"normal","cform-calendar-font-family":"Roboto","cform-calendar-custom-font":"","cform-calendar-font-size":"13","cform-calendar-font-weight":"normal","cform-button-font-family":"Roboto","cform-button-custom-font":"","cform-button-font-size":"14","cform-button-font-weight":"500","cform-timeline-font-family":"Roboto","cform-timeline-custom-font":"","cform-timeline-font-size":"12","cform-timeline-font-weight":"normal","cform-pagination-font-family":"","cform-pagination-custom-font":"","cform-pagination-font-size":"16","cform-pagination-font-weight":"normal","payment_require_ssl":"","submission-file":"delete","form_name":"gbo-autopost","form_status":"publish"},"client_id":null,"notifications":[{"slug":"notification-1234-4567","label":"Admin Email","email-recipients":"default","recipients":"eli_marko@hotmail.com","email-subject":"New Form Entry #{submission_id} for {form_name}","email-editor":"You have a new website form submission: <br/> {all_fields} <br/>---<br/> This message was sent from {site_url}."}]},"status":"publish","version":"1.10.2"}

    Jet engine custom fields variants:
    Country flag => country-flag
    company_role => company_role
    industry => industry
    wpn_customer_type => wpn_customer_type
    subject => subject
    marketing_channel => marketing_channel
    continent => continent

    Any help will be appreciated.

    Thanks,
    Eli.

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @markovetski,

    From what I see Jet engine plugin is a paid plugin and I couldn’t check this further due to that.
    Please get in touch with Jet engine devs to look into this for you.
    You can also have a look at Forminator API docs for help with integrating with custom fields:
    https://premium.wpmudev.org/docs/api-plugin-development/forminator-api-docs/

    Cheers,
    Predrag

    Thread Starter markovetski

    (@markovetski)

    Hi Predrag,

    Thank you for your reply.

    I have view the API ducoment but didn’t fine what I am looking for (maybe I missed it).

    The thing is that when using the form on the front end you can see all the custom fields and also select them.

    But they seems to not appear on the back end post.

    Any idea about that?

    Thanks,
    Eli.

    Plugin Support Adam – WPMU DEV Support

    (@wpmudev-support8)

    Hi @markovetski

    Thanks for response!

    I think this is related also to your other thread where you asked for “dynamic custom fields and taxonomies support” and I’m now starting to think that you might be right on Forminator simply not supporting such setup (though I’m not 100% sure yet).

    Here’s the thing: Forminator does support custom fields and as long as they are implemented in a “WordPress Codex compliant way”, they will be handled. The fact that the form is picking up and showing these fields, suggests that “codex wise” they are indeed custom fields. But screenshots also suggests that they are… taxonomies.

    I’m not quite sure how this works but my guess would be that the plugin that creates them stores “internally” data about taxonomies as post meta – so that makes the Forminator see it. But then they shouldn’t be seen because they are not intended to be used as custom fields but rather based on that data the plugin that you are using is adding custom taxonomies “on the fly”. That’s just a guess but would that be about right?

    if yes, then indeed Forminator doesn’t support that and I think it might actually pose some trouble as it wouldn’t be quite a “standard” way to handle and rather than making Frominator support that we would need to add some sort of ‘compatibility code” for that solution/plugin specifically.

    Kind regards,
    Adam

    Thread Starter markovetski

    (@markovetski)

    Hi Adam,

    Thank you for your reply.

    Actually, I have made some progress but I’m not there yet 🙂

    I have made a video to make it more clear:

    So here are the things that I will need your help on please (I will divide it into 4 parts based on importance):
    User issue
    1. When I am using my Admin/user that has permission to submit posts the custom field selection is working fine.
    2. But when I try to fill the form with a non-registered user (a guest) it only picks up the regular WordPress post fields (‘title’, ‘extract’, ‘content’, etc.).
    Is there a way to make it work to gust as well? Because I don’t want it to work only for registered users. It will make things much more complicated for the visitors and for me.
    Text Custom fields fill in
    I have some simple ACF custom text fields shown as meta-box on the custom post type that I would like to be filed by the non-registered user on the front-end form. Is there a way to do it via your ‘%my_value_1%’ field? or any other way?
    Tag Custom fields fill in
    The same as the last question but this time it’s a Tag field that I would like the user to add data using a comma as a separator for different tags. Is there a way to do that?
    “Blank” fields on the front-end
    On the form, each line of custom filed is showing one of the values, is there an option to show a “blank” place holder or something else?

    Any solution to each of the noted issues will help a lot.
    Thanks a lot for your help and support.
    Eli.

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @markovetski,

    I trust you’re doing well!

    User issue

    I’ve created a similar setup, with a free custom post type plugin and could replicate the same issue. That when a logged out user submits post data the data is not coming through.

    I’m afraid this is a bug and I ‘ve forwarded it to our developers so they could fix it. If a hotfix will be available before the official plugin update we will share it in this thread.

    Thank you for letting us know about this issue.

    Text Custom fields fill in
    Tag Custom fields fill in
    “Blank” fields on the front-end

    I’ve forwarded your question to our developers, as for an autofill feature for a custom field requires custom coding, it is not possible out of the box. Once the will be an update we will post back in this thread.

    Have a good day and take care!

    Kind regards,
    Nastia

    Thread Starter markovetski

    (@markovetski)

    TY Nastia 🙂

    Thread Starter markovetski

    (@markovetski)

    Hi folks,

    I just wanted to know if you have any update on that.

    And also I would like to wish you all a Happy new year and thanks for your efforts.

    BR,
    Eli.

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi Eli,

    I’m afraid that users on front end can only choose from existing taxonomies, adding new ones would require custom development.

    Cheers,
    Predrag

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hello @markovetski

    I hope you are doing well!

    We haven’t heard back from you for a while now so we’ve marked this ticket as resolved. If you do have any followup questions or require further assistance feel free to reopen it and let us know here.

    Kind regards,
    Nastia

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Create post doesn’t fill up the custom fields in the post.’ is closed to new replies.