OpenSearchServer Search
Create Index returning blank page. (5 posts)

  1. kevinlyles
    Posted 2 years ago #

    I am trying to setup this plugin and when I click create index it loads the admin page but the content is blank.

    Can some one help me fix this?


  2. justinwpw
    Posted 2 years ago #

    Hello. You need to make sure that you have entered your privileges correctly in the section at the top - Instance Settings. Tip: if you are using admin as your login name for OpenSearchServer, make sure you re-enter this login name in that field of the Instance Settings form. It already has admin in that field, but you need to actually type it in there to enter it properly.

    Also, make sure that you have selected your options in the section Query Settings.

    Then try clicking Create Index under Index Settings.

    Finally, click the Synchronize / Re-index button.

  3. ekeller
    Plugin Author

    Posted 2 years ago #

    I suggest also to use the last version (1.2.2).
    Kevin, did you finally make it works ?

  4. athalas
    Posted 2 years ago #

    Thank you for the replies.

    I've updated the plugin to 1.2.2 but not having much luck with it.

    After entering my instance settings and selecting 'Update Instance Settings' everything is looking good.

    I then proceed to to add a Facet Field: Title and select Add, everything still looking good.

    I select:

    Spell check: Title
    Default language: English
    Display: tick category

    after then clicking on 'Update Query Settings' all of my settings is lost and I can't continue.

  5. athalas
    Posted 2 years ago #

    Further my previous message, I've checked my error log:

    PHP Warning:  CURL failed to execute on URL "/schema?cmd=indexList" in ../wp-content/plugins/opensearchserver-search/lib/oss_abstract.class.php on line 169
    PHP Warning:  Invalid argument supplied for foreach() in ../wp-content/plugins/opensearchserver-search/lib/oss_schema.class.php on line 52
    PHP Warning:  CURL failed to execute on URL "/schema?index.name=&cmd=createIndex" in ../wp-content/plugins/opensearchserver-search/lib/oss_abstract.class.php on line 169
    PHP Fatal error:  Call to a member function xpath() on a non-object in ../wp-content/plugins/opensearchserver-search/opensearchserver_admin.php on line 44

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • OpenSearchServer Search
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic