Support » Plugin: WooCommerce » “create an account” not translating

  • Resolved sirrahikkala

    (@sirrahikkala)


    For some reason the text at the cart/checkout where it ask whether customer wants to create account with the check box “create an account” does not translate (3.6.5). I’m using also Loco translate and synced the source and emptied caches etc. Anyone can confirm?

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Support grigaswp

    (@grigaswp)

    Hi there,

    Thank you for reaching out!

    I’ve tested this and I am able to translate this string with Loco Translate on both WooCommerce 3.6.4 and 3.6.5:

    https://cld.wthms.co/HFJF9S

    https://cld.wthms.co/iVLDxD

    I don’t see a link to your site but I’d guess that one of the plugins on your site modifies this checkout area and the translation might need to be done under that plugin and not the core WooCommerce plugin itself in Loco Translate. This section might also be overridden by your theme so searching for this string under your theme in Loco Translate could help.

    A simple plugin/theme conflict test should show which plugin (or your theme) is responsible for this:

    https://docs.woocommerce.com/document/woocommerce-self-service-guide/#section-4

    I hope this helps!

    Hari Shanker R

    (@harishanker)

    Automattic Happiness Engineer

    Hi @sirrahikkala

    I was able to replicate the same behaviour shown in @grigaswp’s screenshots in my tests as well. I could successfully translate the string without any troubles. Doing a full conflict test might help you get to the bottom of this.

    I’m marking this thread as Resolved for now, but feel free to reach out if the problem persists.

    All the best!

    This issue still persists for some reason. Even after the last woocommerce update. Loco translate does not change the string.

    Plugin Support grigaswp

    (@grigaswp)

    Hi there,

    This issue still persists for some reason. Even after the last woocommerce update. Loco translate does not change the string.

    Thank you for the update!

    I’ve re-tested this and I’m still able to change this string using Loco Translate on my test site:

    https://d.pr/i/ZzgfPR

    https://d.pr/i/exT34F

    It sounds like this behaviour is isolated to your WordPress/WooCommerce install.

    If you are unable to find and translate this string under one of your plugins, or your theme, and you’d like to know the source of this behaviour – you can do a plugin/theme conflict test:

    https://docs.woocommerce.com/document/how-to-test-for-conflicts/

    For additional assistance with translations, you may also want to reach out to Loco Translate support team:

    https://wordpress.org/support/plugin/loco-translate/

    By comparing the screen, I can see that I have 5,862 strings whereas your screenshot shows 5631. What could be behind this? I have “synced” the file.

    https://imgur.com/a/VTZfMzY

    • This reply was modified 10 months, 3 weeks ago by sirrahikkala.
    Plugin Support grigaswp

    (@grigaswp)

    Hi there,

    By comparing the screen, I can see that I have 5,862 strings whereas your screenshot shows 5631. What could be behind this? I have “synced” the file.

    After clicking the “Sync” button in Loco Translate, I see 5,862 strings now, too:

    https://d.pr/i/XPjo6E

    The translation still works on my test site and I’m positive this behaviour is caused by either your theme or some of the plugins you’re using.

    Hey, i had same issue and i used Loco Translate to translate Klarna checkout plugin and there was that missing “Create an account?” with out translation. Hope this help out sirrahikkala

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘“create an account” not translating’ is closed to new replies.