WordPress.org

Support

Support » Plugins and Hacks » [Resolved] "Create additional configuration" not showing

[Resolved] "Create additional configuration" not showing

  • Hello,

    I have installed and configured your plugin on a local installation of wordpress 3.9 successfully.
    However, I tried this morning to update my production website. Everything went smoothly with woocommerce (2.1.8) and other plugins but I am facing a problem with “Weight based shipping” plugin.

    Symptoms:
    “Create additional configuration” button is never showing (it was on my local install).
    And the first time I try to save parameters, it says they are saved but they appear they are not saved. Second save is OK – not sure both are related, as I may have had that one on my local install too but I am not 100% sure.
    However, I can’t add any other configurations as the button is not showing…

    BTW, good job with this feature, I wish other plugins have this functionality too.

    I have tried lots of things, including deactivating all plugins and switching theme with no luck.

    Any pointers where to look at?
    Might this be server related?

    Samuel.

    https://wordpress.org/plugins/weight-based-shipping-for-woocommerce/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Did a fresh install of WP 3.9 on my server.
    Installed only woocommerce + weight based shipping plugin.
    Same problem. I confirm that settings are not saved the first time I press save.

    Downgraded to 3.8.3. No improvement.

    OK, I think I got it.
    I am really no php expert, last time I did some php was more than 10 years ago, but I got it working by replacing in the plugins php file, all occurrences of “<?=” by <?php echo >”

    My server php version is 5.3.20

    Hopefully this will help someone else…

    Plugin Author Dan
    Participant

    @dangoodman

    Hi!

    Sorry for the lateness I was away from home and wasn’t able to answer you.

    Thank you for the fix you proposed. I’ve replaced short php tags with their full equivalents so you can upgrade safely.

    The issue with broken first time saving is fixed also now.

    These both fixes included in the new plugin version 2.2.3.

    Hello,
    No worries, I do not expect pro support from a free plugin. And I’m glad my fix can help other people too.
    Thanks for this very useful plugin BTW.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘[Resolved] "Create additional configuration" not showing’ is closed to new replies.