Support » Fixing WordPress » Crazy long delay when I click write post/page WP 2.5

  • Resolved davidinjp

    (@davidinjp)


    Upgraded to v2.5 smoothly. Everything is real nice (even my non-embedded wpg2 stuff), image uploader works good etc.

    Problem is that every time I click to write (new) or edit a post or page, it takes like 2 minutes for the edit page (where you input text) to load. I tried deactivating ALL plugins, restarted apache, disabled xcache, but nothing seems to fix this problem.

    After 2 minute wait I am able to write the post as I normally would, but there is another 2 minute hang when I click Save. However, the post is updated right away (as seen in another browser) when I do click save, it’s just the edit page itself has this two minute hanging problem…

    Any suggestions to try to resolve?

Viewing 15 replies - 16 through 30 (of 33 total)
  • I’ve got what I assume is the same problem, though not quite as bad: the little blue box on the right with save/publish buttons appears quickly, and then it takes about 7 seconds for the editing box to appear.

    Another blog on a subdomain of the same server is working fine, so that suggests it’s not down to server settings; it happens whether or not I choose to use the visual editor and with all plugins deactivated.

    There’s this suggestion, but I don’t think it applies to me:

    http://wordpress.org/support/topic/164276?replies=5

    Somewhere I read a suggestion that having lots of categories (which I do) slowed down 2.5 badly, and I suppose I could convert most of them to tags if I thought it would help, but actually I *like* having them hierarchical, so I’d rather not unless I absolutely have to. And it was working just fine in 2.3.3.

    So, I’m out of ideas.

    I have the same problem, but on my work PC was fine… thought it might be a vista thing, but that didn’t seem to pan out.

    Bit of trial and error, wasn’t the network wasn’t any plugins but then thought maybe it’s the virus checker, I disabled the virus checker, and it went all quick again!

    Added my site to my Kaspersky trusted web safe and re-enabled and all is quick agian.

    Might not be a fix for everybody but solved mine 🙂

    Just because I found it again: this is the person who found that changing categories to tags helped.

    http://wordpress.org/support/topic/164713?replies=3

    If I can’t find another solution soon, I may try it myself, but I’m not thrilled by the prospect.

    I suppose this is related, but I tested an ssh access with “mysqladmin processlist “
    And, unlike the short list I had with WP 2.3, I had a very very veeeeeeeeeerrrrrry long list.

    Maybe WP 2.5 is simply managing its requests very badly and that’s a huge load for the mysql server, hence a delay to reply ? ?

    Still did not resolve this one. I have ruled out:

    Not browser, or client side. Tried 3 browsers on two PC’s
    Not mysql, zero activity there
    not plugins, deactivated all
    not the categories to tags thing, converted already
    the action after clicking write/post is instant on the back-end, just not sending to the browser for two minutes later
    there is no server or client side cpu utilization during the delay, just a small spike from httpd.exe of a few percent on server just when the write/post page finally does load

    This is something screwy, thinking I need to blow it all away and try a fresh config and import back to db. If that doesn’t fix it, I will roll back to earlier WP

    I’m having the same problem you’re having except I’m using an old 1.5 version. Two other small exceptions are that I only experience the deal when saving a post, not when loading a post nor when starting a new article, and also that I don’t get confirmation from the host in two minutes. I’ve left it sitting there for an hour, and the little IE world just spins and spins and spins…

    The problem is particular to this host, as WP installations I’ve set up on other hosts with the same exact set of WP files do not have this problem. I’m all but positive it’s not a WP problem but something at the hosting end, but I was hoping to find out more before I try to take it up with the hosting company.

    I ended up giving in and reluctantly converted all my categories to tags, which completely sorted out the problem. I’m still irritated I had to do it, but at least it’s working properly now.

    Just like everyone else, I have the same problem and have tried to sort it out through my server provider.

    It only happens with the write/edit posts requests and nothing else. Also, sometimes it takes so long to post that I get a blank page at the end of publishing or saving, but my browser states it is done. When I check the blog, it is posted if I hit publish.

    I have tried four different browsers, so that is not the issue. Was told it is a back end issue.

    I don’t have many categories, so I don’t believe that to be the problem.

    I have one category (and one post), so I don’t think that’s the problem either. 🙂

    Well, converting all my categories to tags did not help, but upgrading to version 2.51 finally did help. I’m only guessing that the db upgrade did not go well on the original upgrade to 2.5.

    So this problem is resolved for me.

    I am having this identical problem after upgrading to 2.5.1. After much trial and error I determined the following. The problem is definitely related to categories and importing from a previous blog. If I start with a new data base there is no problem at all writing and posting. Then when I import the posts,pages etc. from my old blog at wordpress.com, the writing of posts is a little laggy. (30 second load time). If I import a 2nd time (in order to update the latest post and comments), the lag time increases to 2 minutes. If I wait sufficiently long, I will get an error stating that a script in the program has stopped responding. If I stop the script and view the source of the page I see that the program is running in a loop checking a list of my categories over and over again. I can “fix” it by deleting the Sql DB and starting all over again with a single import.

    gumbah

    (@gumbah)

    What helped for me was the following:

    I used the upgrade guide (http://codex.wordpress.org/Upgrading_WordPress) and forgot to copy and overwrite the wp-settings.php file.

    Everything worked fine except for the “write post/page” part being really slow. I found out that on that page there was some kind of ajax loop (constantly calling admin-ajax.php).

    So make sure you copy and overwrite the wp-settings.php file because it contains the following (crucial) code:

    if ( !defined( ‘AUTOSAVE_INTERVAL’ ) )
    define( ‘AUTOSAVE_INTERVAL’, 60 );

    (line 340 in wp-settings.php)

    Hope this helps some of you!

    I tried all these suggestions and nothing. I have the same exact problem as the original poster (and some of the others) where it is only slow when I click write or I try to save or post.

    I just updated to 2.5.1 and tried the wp-settings.php fix. Tried to deactivate plugins.

    I was having the same problem of slow posting/editing, but fast for everything else. The problem for me was the “Google XML Sitemaps” plugin which generates a sitemap for search engines. I could see that the MySQL changes were written quickly, but then my site would be frozen.

    The fix was to uncheck the various options to notify search engines like MSN, Yahoo and Ask. I think one of them wasn’t responding quickly, and the plugin was taking a long time to timeout. I left Google checked (since they are where most search traffic comes from) and that is fine. Now it is back to very speedy edits/posts. I haven’t gone back to determine which specific service is the culprit.

    And I didn’t convert my categories to tags, and this is on 2.5.1.

    Hello

    I was having poor response time all over the site 15-30 secs for a page to refresh.

    My solution was to change the URL in Settings -> General from http://mydomain.com to http://www.mydomain.com.

    It really looked like the browser was not cahing any images, javascript etc, and loading them again and again, with each new page. This is most evident on the write post pages with all the icons in the post tool bar.

    Its much quicker now. Hope this helps someone.

    Thanks A

Viewing 15 replies - 16 through 30 (of 33 total)
  • The topic ‘Crazy long delay when I click write post/page WP 2.5’ is closed to new replies.