WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] Crazy long delay when I click write post/page WP 2.5

[Resolved] Crazy long delay when I click write post/page WP 2.5

  • Upgraded to v2.5 smoothly. Everything is real nice (even my non-embedded wpg2 stuff), image uploader works good etc.

    Problem is that every time I click to write (new) or edit a post or page, it takes like 2 minutes for the edit page (where you input text) to load. I tried deactivating ALL plugins, restarted apache, disabled xcache, but nothing seems to fix this problem.

    After 2 minute wait I am able to write the post as I normally would, but there is another 2 minute hang when I click Save. However, the post is updated right away (as seen in another browser) when I do click save, it’s just the edit page itself has this two minute hanging problem…

    Any suggestions to try to resolve?

Viewing 15 replies - 1 through 15 (of 33 total)
  • If you are using Firefox or some other browser with plugins, have you tried disabling those? It sounds like a problem with your browser rather than wordpress (since as you say it’s only your browser that won’t reload).

    This might help. Maybe you have a lot of categories, which should be converted to tags.

    It is a server side issue. Same behavior in ff, safari, and IE.

    ingejanse, I took a look at the thread you linked, but my sole remaining photography category only converts to create a new tag, but still remains a category. I can’t actually get rid of the category. I was able to delete the “default” category, but not my “photography” category which was set as the default for new posts before I upgraded to 2.5.

    Also tried changing themes to classic and default… no impact. This is an odd one. I have no php or other other event errors. Strange because everything else in the UI is super fast…

    I too experienced this problem. Within 24 hours of upgrading to 2.5, my site was so bogged down, I could barely log in, much less actually doanything. I was also informed by others that viewing the site was a hit or miss affair (mostly miss).

    I reverted to 2.3.3 and was stunned to see no difference in behaviour. A quick action on the part of my host had me back in business. They told me processes were not ending properly. I can’t say for certain it was 2.5, though the problem started soon after I upgraded. Now that I’ve reverted, the problem hasn’t returned.

    Along with the image upload problem, I’m content to stay with a working 2.3.3 install for a while longer, until fixes for these problems are rolled out.

    rpali, we have different problems. The site and everything in the admin UI performs very well, except for the write/edit post action itself. No other problems.

    @rpali: I have written my host three times this week, and the third just now with a quote from you. I hope they fix this, because I’m about to go nuts.

    Originally, you said reverting to 2.3.3 didn’t help… so what did your host do to make reversion functional for you? Were they unable to provide assistance on version 2.5?

    Hmm, tried a re-install, checked the database, scanned apache and php logs… still nothing… someone else must have run into this problem upgrading. Please let me know if you exist! 🙂

    I have this same problem but no one seems to be able to fix it

    Same here, write/edit slow as hell (Mind you, the notes ARE posted/edited in seconds, but our confirmation takes 2 minutes).
    I noticed it with version 2.3.3, and upgrading to 2.5 didn’t change anything.
    I also moved my database from my current mutualized host to a dedicated box host, courtesy of a friend using the dedi box, and that didn’t change the problem.
    Running an optimization of the DB in phpmyadmin didn’t change it either.

    I guess, guys, we will have to wait until a smart guy finds the solution :-/

    For me it didn’t happen until I upgraded to 2.5, so it’s something that was triggered by 2.5 since nothing else changed.

    I also went through and manually diff’ed every file from my site against the full 2.5 WP install. Everything is as it should be. So somewhere there is an offending bit of code in the 2.5 files.

    I did some tracing and resource monitoring too. The long delay may be as simple as bad HTML or CSS. I confirm there is no database activity after the initial click. It’s something in PHP or httpd is chocking, although everything shows zero resource utilization.

    Maybe my info can help, on my side the techies of my VPS account told me they took a look at the logs of my sql server, and there was no abnormal behaviour, no extreme consumption of resources.

    I also noticed that the problem is worse for some pages, I use the kgarchives plugin that replaces the archive page with a one-page list of ALL the posts (without excerpt, just the title and they are sorted by category) and that page may take now 10 minutes to load.

    I wish I could help more tracking the bug !

    By the way, the matter is also discussed on that other thread : http://wordpress.org/support/topic/164497?replies=13 . Sharing the info is important, please, if you finally find a solution here, be kind enough to talk about that on the other thread too 🙂

    The other thread (http://wordpress.org/support/topic/164497?replies=13) is an entirely different problem from my own.

    Once again, the only problem I have is that my Edit/Write pages take forever to load. There is no impact on the rest of the site or visitors to the website.

    shetakaey,

    What I did when I saw 2.3.3 was also having the same problem was open a support ticket with my host. Everything suddenly started working again and a few moments later I received a message that said, in part: “Your Apache processes weren’t dying off correctly/normally but I don’t know why. I’ve restarted your account and things are loading fine now.” She specifically stated there was no issue with the database. It was strictly with Apache. Very strange…

    davidinjp,

    Sorry about the mix-up. What you described sounded familiar so I ran with it. Possibly part of the reason is I first noticed the problem when trying to edit/post a new item. Then the media viewer was affected, and it spread from there until nothing worked.

    No problem rpali. I just hope I can find someone else with the same problem. I can usually fix any problem on my own so this one is driving me nuts!! :=)

Viewing 15 replies - 1 through 15 (of 33 total)
  • The topic ‘[Resolved] Crazy long delay when I click write post/page WP 2.5’ is closed to new replies.
Skip to toolbar