WordPress.org

Support

Support » How-To and Troubleshooting » craziest problem i have ever witnessed with images

craziest problem i have ever witnessed with images

  • Mike

    @mikedark

    this one is pretty funny if I wasnt pulling my hair out. its really quite unbelievable.

    I am having problems displaying images in posts. i have searched the forums and found many other having this problem with 2.8.x, typically after upgrading from 2.7, although mine was not an upgrade (though i did do a server migration)

    in an attempt to narrow down the problem, heres what i discovered:

    – no matter what workaround i tried nothing seemed to work.
    – i already had some images uploaded into the themes/theme/images folder that i used for the site design
    – to experiment i used a direct path for one of these images in a post and it worked. the image displayed.
    – next, i uploaded a new image to the same folder via ftp (so it cant be a problem of permissions). then i edited the post and simply replaced the name of the one image file that was showing for the name of the new image file that i just uploaded into the same directory.

    magically, the new image does not get displayed. How on earth could this be possible???

    i would really appreciate any help as i am helping launch this site for a friend who is a professional musician and his whole record label is about to launch a PR campaign to support his new project and now he’s trying to write his first blog post and cant get images to display.

    thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • esmi

    @esmi

    Forum Moderator

    Are you using relative or absolute urls for images in posts?

    Mike

    @mikedark

    Hi, I am using absolute

    esmi

    @esmi

    Forum Moderator

    Any chance of a link to the site? What type of server is it running on?

    Mike

    @mikedark

    esmi, thanks for your help.

    Running on cPanel/Hostgator.

    i built the site on a test server, then migrated over to another server where the actual site will be (both are cpanel/hostgator). I went back to the test server and checked there, and its the exact same problem. so it doesnt seem to be a result of the migration.

    here are two links to single posts on the test domain:

    http://1.dnfu.net/2009/09/link-to-song/

    On that one you can see i put an image on the upper right of the post and it displays fine. (this is the same image that you see if you scroll down a bit to the ‘Contact Info’ image) I chose that image since I knew I was already using it on the site with no problem

    http://1.dnfu.net/2009/09/countdown-to-launch-sequence/

    On that post you can see there is a blankness where there should be an image (I put a border around it)

    now, the only difference in the two posts is the path to the image file, which are, respectively:

    http://1.dnfu.net/wp-content/themes/thesis_151/images/contacts.png
    http://1.dnfu.net/wp-content/themes/thesis_151/images/toronto.jpg

    both of these images were uploaded through FTP and are there in the same directory.

    interesting to note, to insert the image i used the image uploader but since i already had the images uploaded i chose ‘add media file from URL’ option, and just put in the direct path. however when i used the first image (the good one) it gives me a little green check mark next to the field, and then allows the ‘insert image’ button to be clickable. when i used the path for the second one (the image that doesnt show) it displays a red X next to the field and doesnt allow the ‘insert image’ button to be clickable, (meaning it is not recognizing that there is an image where there is one)

    like i said, crazy. its drving me up the wall.

    Mike

    @mikedark

    how come this didnt get ‘freshed’ to the top of the line after my last post?

    Mike

    @mikedark

    Okay. to update, I just have this same problem happening on another one of my blogs now. and I think this is a version 2.7.x (not sure where to find the version info) but it is definiately not 2.8.4

    i am wondering if this had something to do with running Ad-block plus in firefox. a quick google about it and at least one other person said this

    https://adblockplus.org/forum/viewtopic.php?t=4475

    except i have also tested this in IE and it seemed to be no different

    am going to try removing adblock plus and see what happens

    Mike

    @mikedark

    ah, wait. i’ve noticed also that when i went in wordpress to ‘Settings’ > ‘Miscellaneous’ and for ‘store uploads in this folder’ I had C:\wamp\www\wp/wp-content/uploads (since i built the site locally on my wamp server)

    I have changed this already prior to my testing with the original site. What i’m now wondering if it left something in the database that would need to be corrected. is that a possibility?

    since I also just discovered on my other blog that i also had not changed that folder name since i moved to a live server, that this might be the root of the problem since they both have that in common

    esmi

    @esmi

    Forum Moderator

    Very likely! Try amending it to the correct path (e.g. wp-content/uploads)

    Mike

    @mikedark

    I think i’ve solved the problem!!! whooo!!!

    for those of you who come after and find this thread, here’s what i discovered:

    first, I disabled both Firefox No-Script and AdBlock Plus addons. I’m not positive whether either of these had a had in the problem but there is a definite possibility that one of them was screwing with the code. Theres a lot of other posts about this causing a problem.

    When in FTP, i kept noticing after uploading images through the wordpress media library it was creating the folder C:\wamp\www\wp/wp-content/uploads, even after I had changed the miscellaneous settings to /wp-content/uploads

    my FTP client wasn’t allowing me to delete this directory. so i opened up file manager in cpanel and used that to delete it. however this is not where the images were being dumped. What i finally figured out was that wordpress was creating another folder inside the wp-admin folder with the same path, and that is where the images were getting uploaded.

    in the end i wiped out any folders that were c:\wamp\www\… (it was also creating a folder called ‘http:’ which was empty. not sure why

    then after this when i used the uploader it created the appropriate directory.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘craziest problem i have ever witnessed with images’ is closed to new replies.