Support » Plugin: User Access Manager » Crashes

  • With new update they demand to have at least php 7.3 and then the site crashes. Why not just approve to use the plugin with 7.2 as well, not that big difference

    • This topic was modified 9 months ago by jenshagman.
Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Author GM_Alex

    (@gm_alex)

    Hi @jenshagman,

    PHP 7.2 is end of life and doesn’t get security updates anymor. WordPress requires PHP 7.3 as well. Rating the plugin like that because you environment isn’t up-to-date, well…

    Thread Starter jenshagman

    (@jenshagman)

    Well, no other plugin of our 70 plugins demands this and wordpress works very good with 7.2. Thats why I think its worth 1 star that you have so high demands on PHP as no one other has. Can you make your plugin to work with 7.2 but with a tip that you PREFER 7.3 then I change the review star

    Plugin Author GM_Alex

    (@gm_alex)

    To be honest I hate to be blackmail. Instead of asking kindly if I could change the minimum required version to 7.2 you rate it with one star and tell me that you only increase the rating if I do what you want? What would you do if some one act like you and rate your bike shop bad because the don’t like your decisions to only sell some brand you are thinking is good instead of asking if you could get him the brand he likes? But luckly I’m not that kind of person how acts like an (fill in the word you prefere to descripe some one how acts like you) and will change it in some upcoming release. But please keep the rating and instead consider the next time how you tread people who offer you there work for free.

    A big thumbs up for GM_Alex, it is so anoying seeing people screaming about things they don’t understand.
    Why would you hold on to a none supported EOL PHP version ?, and that even with 70 plugins (that’s a big risk !!! )
    I am using this plugin for 6 years now without any problems, and i am on 7.4.

    I’ll rate it with at least 5 Stars, keep up the good work

    Thread Starter jenshagman

    (@jenshagman)

    Wow! If you want to take feedback and call this blackmail its up to you and I feel sorry if you take it that way. I feel that the plugin is totally worthless when you put this demand on 7.3 when so many other plugins dont do it. Why you take this so personally instead of just listen on the users feedback. If you dont want to change it, its up to you but I pretty sure many others that uses 7.2 is very disappointed that they cant use your plugin now. Why cant the user decide if they want to upgrade to 7.3 or not? Recommend user to use 7.3 would be a much nicer experience for the users but I feel that you dont want to listen because you take this as a threat/blackmail.

    Plugin Author GM_Alex

    (@gm_alex)

    Can you make your plugin to work with 7.2 but with a tip that you PREFER 7.3 then I change the review star

    Think again about what you wrote. That’s blackmailing, no feedback and has nothing to do with not listing. And again WordPress requirement was PHP 7.3 since I released the last version, now it’s 7.4, see https://wordpress.org/download/. Even if runs with a version lower than that, it’s not a wise decision to do so. But I mad my standpoint clear, if you are not willing to listen, because you aren’t listening, it’s up to you.

    Thread Starter jenshagman

    (@jenshagman)

    I understand that its important for you to make a stand and I get it and I said im sorry. You must understand that its very frustrating for your customers when all work we have put into this solution with your plugin now get lost and we have to build a new solution. Why just not let the customer choose which safety thats important for them? Its very frustrating with this concept with wordpress that every pluginmaker can make this kind of decision to exclude and dont let the customer to choose.

    Moderator Jan Dembowski

    (@jdembowski)

    Forum Moderator and Brute Squad

    *Reads. Raises hand.*

    I’ll try to keep this lighthearted.

    To be honest I hate to be blackmail.

    @gm_alex That’s not blackmail or extortion. We get those all the time here and that is dealt with. This is the whole review.

    Crashes

    With new update they demand to have at least php 7.3 and then the site crashes. Why not just approve to use the plugin with 7.2 as well, not that big difference

    That’s feedback that an outdated, insecure, using it is just a bad idea, the host should be ashamed and feel really bad, version of PHP 7.2 is not supported.

    *Drinks coffee*

    While I personally do not believe that would be something any developer do work to support, it’s still feedback. Don’t take it personally. Honestly, do not.

    You must understand that its very frustrating for your customers

    Ha! No. *More coffee*

    @jenshagman is not your customer. There are no customers on this site and never has been. He’s your opensource collaborator providing feedback in this review.

    So please. Keep it civil and just consider walking away from this feedback. That applies to both people.

    Maintaining a plugin is a big responsibility, particularly when it deals with users (so privileges).
    Plugin authors cannot be expected to (nor is it always a good idea to) maintain perfect backwards-compatibility.

    If you are unwilling to update to PHP 7.3+, perhaps the solution is to continue using an old version of the plugin as well?
    I do not recommend using an old version of the plugin, but in the same breath, I really do not recommend a version of PHP that has reached end-of-life either.
    Choices are not free of consequence.
    The consequence of your choice not to update PHP here is that you are not able to continue to use new versions of the plugin.
    It may be the first plugin that you have had this experience with, but others will follow – perhaps sooner than you are prepared for.

    Thread Starter jenshagman

    (@jenshagman)

    @carike

    Yeah, thats what I would like to do and trying to feedback to pluginmaker. Using the old version would probably more than us would like to use but didnt know this demand of 7.3 when we updated the plugin.

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    @gm_alex Note: If you had used Requires PHP: 7.3 in the plugin header, the plugin would not update on a 7.2 system. See https://developer.wordpress.org/plugins/plugin-basics/header-requirements/#header-fields

    Plugin Author GM_Alex

    (@gm_alex)

    @jdembowski To be honest it wouldn’t be a big deal if some one open a support request to support PHP 7.2, I had updated the CI and that’s it. Also if some one would rate it with for example three stars and mentioned that. But whats absolutely frustrating is that some using a free piece of work for maybe a long time, is happy with it and then something happens they don’t like and rates it the baddest possible value. I talked a lot with other open source developers and that’s the main reason the stop there work. Don’t get me wrong, I learned to accept that, but what grinds my gear is if than people start things like, change it and I (maybe) adjust the rating, that feels like blackmailing. But I don’t want to make it bigger than it is. I made my point and I will change the minimum version to 7.2 if it doesn’t break something.

    @sterndata I didn’t know that. I will definitely add this. Thank you very much.

    Moderator Steve Stern (sterndata)

    (@sterndata)

    Forum Moderator & Support Team Volunteer

    As a former tech writer, I feel compelled advise RTFM occasionally. 🙂

    Plugin Author GM_Alex

    (@gm_alex)

    Version 2.2.10 with PHP 7.2 and the awesome Requires PHP: 7.2 plugin header (thanks again @sterndata) is now available.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Crashes’ is closed to new replies.