Support » Plugin: Activity Log » Crashed site, now won’t activate

  • Resolved conradb1989

    (@conradb1989)


    I’ve used the Activity Log plugin for years now with no issues, but this morning my site crashed after an update and after removing / adding the plugins one-by-one, it was this plugin at fault. Now, when I go to reactivate it, I get the following error;

    Parse error: syntax error, unexpected ‘[‘ in /home/sites/technicalnode.com/public_html/wp-content/plugins/aryo-activity-log/classes/class-aal-privacy.php on line 13

    I’ve completely removed the plugin and tried reinstalling it but I still get the same error. I find the plugin really useful and don’t want to get rid of it, but will have no choice unless you have any suggestions for the above error?

    Many thanks,

    Conrad

Viewing 6 replies - 1 through 6 (of 6 total)
  • roaldb

    (@roaldb)

    The same hear I use the Activity Log plugin for more then 5 year never had a problem.
    On 16 https (and 1 http) wordpress websites version 2.50 works,
    Just 1 http website the “activity log” plugin crashes the site. (Http 500)
    The same crashing website working with another internetprovider works.
    Disabling the plugin version 2.50 makes the site working again.
    Re storing the old versie 2.41 works to.
    The class-aal-privacy.php is a new file. It doesn´t exist in version 2.41.

    The differences between the internetproviders are.
    Crashed website is with php version 5.5
    All the other websites are php 5.6 or higher ( up till 7.1)

    My only solution is keep working with version 2.41 and disable auto update of plugins.

    I hope will be a solution soon.

    Thanks in advance

    Roald

    Plugin Author Yakir Sitbon

    (@kingyes)

    We working on it. Thanks!

    I think I have the same error. It crashed the site, so after some FTP efforts, I deactivated the plugin. My site is running now, minus your plugin.

    Trying to reactivate, I get the following messages: “Plugin could not be activated because it triggered a fatal error.” and Parse error: syntax error, unexpected ‘[‘ in /hermes/bosnacweb04/bosnacweb04ah/b2401/nf.alephblog/public_html/alephblog.com/wp-content/plugins/aryo-activity-log/classes/class-aal-privacy.php on line 13

    I am running WP 4.9.8 and the version of the plugin causing the error is 2.5.0

    Plugin Author Yakir Sitbon

    (@kingyes)

    We just released this patch. Please upgrade to new version (2.5.1).

    Just update to version 2.51 on the website dat crashed with version 2.50.

    Working like it used to do.

    Thanks for the quick response.

    Greetings Roald

    Thanks for the quick response. It is working now.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Crashed site, now won’t activate’ is closed to new replies.