Support » Plugin: Free Shipping Label » Crashed Site

  • Resolved GregW

    (@gwmbox)


    As soon as I installed this plugin my site crashed. I had to go into FTP and delete the plugin manually from my plugins folder to get my site up and running again. Lucky I use a test site first.

    Using WP 5.6, WooCommerce 4.8 and other various plugins. All plugins are maintained up to date.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Marin Matosevic

    (@marinmatosevic)

    Hi Greg,

    I’m sorry for the inconvenience.
    What does the error log say?
    Which theme and plugins do you use?

    I’m assuming there is probably some conflict with the theme or other plugin.
    We are running this plugin on several sites with various setups and everything is working perfectly without any errors.

    Best regards

    Thread Starter GregW

    (@gwmbox)

    Sorry I have removed it now. If I get a chance later I will try and reinstall on another test site and get any errors.

    The fact remains that the site with all of its plugins was working before installing this, after it crashed, removing it fixed it.

    Thread Starter GregW

    (@gwmbox)

    2020-12-16T01:52:31+00:00 CRITICAL syntax error, unexpected ‘)’ in /home/123/domains/wc.123.com/public_html/wp-content/plugins/free-shipping-label/admin/class-fsl-settings.php on line 198

    123 to remove actual site

    • This reply was modified 2 months, 2 weeks ago by GregW.
    Plugin Author Marin Matosevic

    (@marinmatosevic)

    I’m not sure why it reports a syntax error. The syntax is fine. That’s really strange…

    Which PHP version you have installed?

    Thread Starter GregW

    (@gwmbox)

    7.2.31

    Plugin Author Marin Matosevic

    (@marinmatosevic)

    Indeed there was a syntax error, you were right, and thank you for reporting it.
    It’s still enigmatic why this error showed only on some installations. I’ve managed to reproduce it only on the latest WP/WC, and php 7.2.22.

    The new (2.0.2) version is released and the error is fixed.

    Best regards

    Plugin Author Marin Matosevic

    (@marinmatosevic)

    We haven’t heard back from you in a while, so I’m going to go ahead and mark this thread as resolved. If you have any other questions please feel free to start a new thread.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.