Support » Plugin: Events Manager - OpenStreetMaps » Crash with last update

  • Resolved fabien79

    (@fabien79)


    Hi, all website crash after last update, this is my log error :

    PHP Fatal error: Can’t use function return value in write context in /public_html/wp-content/plugins/stonehenge-em-osm/stonehenge-em-osm.php on line 69

    Thanks

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    Are you using version 1.8.6.1 or 1.8.6.0? The latest version is exactly the same as 1.8.5.2 so that should not give you any problem, else you should’ve had it with 1.8.5.2 as well.

    Thread Starter fabien79

    (@fabien79)

    It’s Version 1.8.6.1
    I can not activate it anymore, i’ve got this error when i try:

    The extension could not be activated because it triggered a fatal error.

    Fatal error: Can’t use function return value in write context in /home/public_html/wp-content/plugins/stonehenge-em-osm/stonehenge-em-osm.php on line 69

    how can i get previous versions ?

    Thanks

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    The strange thing is that line 69 just gets the language settings of your blog, so it should not cause any errors…

    Since I am not able to reproduce the error myself, would you please try something for me?

    In stonehenge-em-osm.php, please delete lines 65-85 (The complete function “load_textdomain” and then also delete line 44 (that triggers the deleted function).

    If the plugin then works, I know where to look for the solution.
    Many thanks in advance!

    Thread Starter fabien79

    (@fabien79)

    Thanks, yes it works.
    For info, my default language blog is french.

    THanks

    Plugin Author Stonehenge Creations

    (@duisterdenhaag)

    I will mark this as solved, as it was addressed in an update.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Crash with last update’ is closed to new replies.