Viewing 4 replies - 1 through 4 (of 4 total)
  • Same for me

    Just happened here too.

    Site crashed after updating from 2.1.9 to 2.2.0.

    For anyone encountering the same issue with the WooCommerce Satispay plugin causing errors on your WordPress site, here’s a concise temporary fix that can be applied via cPanel or FTP. This solution involves commenting out a specific section of code in the plugin file to bypass the error until an official update is released by the developers.Temporary Fix via cPanel or FTP

    Step 1: Access your site’s files through your hosting account’s cPanel or via an FTP client like FileZilla.

    Step 2: Navigate to the WooCommerce Satispay plugin directory located at /wp-content/plugins/woo-satispay/.

    Step 3: Open the woo-satispay.php file for editing. In cPanel, use the File Manager to locate and edit the file. If using FTP, download the file, open it in a text editor, make your changes, and then upload it back to the server.

    Step 4: Comment out lines 38 to 48 by adding // at the beginning of each line to prevent the plugin from attempting to load a missing file. It should look something like this:

    // function woocommerce_gateway_satispay_woocommerce_block_support() {
    //     if ( class_exists( 'Automattic\WooCommerce\Blocks\Payments\Integrations\AbstractPaymentMethodType') ) {
    //         // require_once 'includes/blocks/wc-satispay-blocks.php';
    //         add_action(
    //             'woocommerce_blocks_payment_method_type_registration',
    //             function( Automattic\WooCommerce\Blocks\Payments\PaymentMethodRegistry $payment_method_registry ) {
    //                 $payment_method_registry->register( new WC_Satispay_Blocks );
    //             }
    //         );
    //     }
    // }
    

    Save your changes. If using cPanel, save directly in the File Manager editor. If using FTP, ensure you upload the modified file back to its original location.

    This fix is intended as a temporary solution to get your site up and running without the specific error caused by the WooCommerce Satispay plugin. Remember to revert any changes once an official fix is available.

    Plugin Author Satispay

    (@satispay)

    Salve,

    E’ stata rilasciato un nuovo aggiornamento che risolve il problema.
    Qualora non sia possibile aggiornare o usare il sito, cancellate la folder in: /wordpress-folder/wp-content/plugins/woo-satispay/ dopodiché aggiornate scaricate e installate il plugin.

    = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = = =

    Hello,

    a new update has been released and it solves the crash of the latest release.
    If you cannot access your website, please manually delete this folder and try to download our plugin again:
    /wordpress-folder/wp-content/plugins/woo-satispay/ then download and install the newest version.

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this review.