Support » Plugin: Add-on WooCommerce - MailPoet 3 » crash site php error is_checkout()

  • Hi, my site stopped working after installation and configuration Add-on WooCommerce MailPoet 3 ver 1.1.0

    This is error php debug:

    Fatal error: Uncaught Error: Call to undefined function is_checkout() in /nfsmnt/hosting2_1/c/c/cc9070a6-6022-4286-b99a-b7f33c20ffcc/url.sk/web/wp-content/plugins/add-on-woocommerce-mailpoet/includes/class-mpwa-frontend-fields.php:191 Stack trace: #0 /nfsmnt/hosting2_1/c/c/cc9070a6-6022-4286-b99a-b7f33c20ffcc/url.sk/web/wp-includes/class-wp-hook.php(286): mpwa_frontend_fields_init_posts_selection(‘ AND ( \n ( bqv…’) #1 /nfsmnt/hosting2_1/c/c/cc9070a6-6022-4286-b99a-b7f33c20ffcc/url.sk/web/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #2 /nfsmnt/hosting2_1/c/c/cc9070a6-6022-4286-b99a-b7f33c20ffcc/url.sk/web/wp-includes/plugin.php(453): WP_Hook->do_action(Array) #3 /nfsmnt/hosting2_1/c/c/cc9070a6-6022-4286-b99a-b7f33c20ffcc/url.sk/web/wp-includes/class-wp-query.php(2602): do_action(‘posts_selection’, ‘ AND ( \n ( bqv…’) #4 /nfsmnt/hosting2_1/c/c/cc9070a6-6022-4286-b99a-b7f33c20ffcc/url.sk/web/wp-includes/class-wp-query.php(3230): WP_Query->get_posts() #5 /nfsmnt/hosting2_1/c/c in /nfsmnt/hosting2_1/c/c/cc9070a6-6022-4286-b99a-b7f33c20ffcc/url.sk/web/wp-content/plugins/add-on-woocommerce-mailpoet/includes/class-mpwa-frontend-fields.php on line 191

    My plugins ver:
    Add-on WooCommerce MailPoet 3 ver 1.1.0
    woocommerce ver. 3.4.2
    mailpoet 3 ver. 3.10.1
    WordPress ver. 4.9.8

    which can be a problem?

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author ehsantikweb

    (@ehsantikweb)

    Hi @lukas-prelovsky,
    We’ve tested and didn’t get any problem here,

    A plugin conflict may be one of the reasons for this issue.
    To find which plugin is causing the conflict please follow these steps:

    1. Go to your plugins page > Deactivate all active Plugins
    2. Update WordPress and Enfold to the latest version if you have not.
    3. Make sure all the plugins are updated.
    4. If the problem does not persist when plugins are turned off, activate one plugin at a time and refresh until you find the plugin in conflict.

    We await the results of your plugin compatibility test.

    Thanks for your cooperation 🙂

    Best regards

    • This reply was modified 8 months, 4 weeks ago by  ehsantikweb.

    I had http 500 error, when i deactivated the plugin, it worked again, please help me with that

    Same problem here after a few weeks.

    • This reply was modified 4 months, 3 weeks ago by  pictibe.
Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.