WordPress.org

Support

Support » Plugins and Hacks » CQS not supported for WP 2.3

CQS not supported for WP 2.3

  • I have a database error since I have upgraded my WP to 2.3.
    After a while, I found the errors come from CQS. But this plugin is no more supported.
    Is somebody (better than me) could look at it ?

Viewing 5 replies - 1 through 5 (of 5 total)
  • Andy Beard adopted that plugin so maybe he’ll be updating it for 2.3

    http://andybeard.eu/wordpress-plugins/custom-query-string-utw

    I have modified it myself :

    [Moderated: Too much code. Please consider placing the code in a text file on your site with a link here -or- use a pastebin service such as http://wordpress.pastebin.ca. Thanks!]

    I will be updating, and also having it listed in the SVN repo to make life easy for people

    maybe a solution… tested it on my testblog, and I think it works ;o)

    in custom-query-string.php (line 252) change:

    … SELECT cat_ID FROM $wpdb->categories WHERE category_nicename = …

    to:

    … SELECT term_ID FROM $wpdb->terms WHERE slug = …

    I have verified that the modifications work great.

    in custom-query-string.php I changed the following text (just search in Vi for “cat_ID” and you’ll find it):

    SELECT cat_ID FROM $wpdb->categories WHERE category_nicename =

    to…

    SELECT term_id FROM $wpdb->terms WHERE slug =

    That has worked well on my blog and I have had no problems whatsoever.

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘CQS not supported for WP 2.3’ is closed to new replies.
Skip to toolbar