Support » Plugins and Hacks » [Resolved] CQS no longer working :(

[Resolved] CQS no longer working :(

  • Ok as a last resort, i’m posting here to try to find an answer to my question. I recently upgraded my wordpress blogg to 2.1.3, and in my previous version i was using the Custom query string plugin to set the number of posts displayed in my archive page.

    As this plugin is no longer working with the new wp version, i wonder how on earth do i set the number of posts to display for that (or a specific) page? I’ve searched for an similar plugin with no result.
    And i’m aware of the set nr of posts in the admin, and that setting is not helping me.

    Please help me! it would be greetly appreciated, im running a photoblogg and right now only 5 posts is displayed wich is really annoying!

    Thank you!

Viewing 14 replies - 1 through 14 (of 14 total)
  • What version of the plugin are you using?

    I am using cqs v2.7, hope u can help me!

    I’m using CQS 2.7 with WP 2.1.3 and it works fine. I have 5 posts on my front page, 10 in the archives. You have have a look at my site for yourself!

    Do you have a clash with another plugin? Try disabling the others and see if that fixes it.

    Hi! I would like to use CSQ, but I can’t find it anywhere since the developer is not supporting it anymore.

    Anybody could send it to me?

    For now you can copy the plugin code and save it as custom-query-string.php in your wp-contents/plugins/ folder:

    Orphaned Plugins needing Adoption/Custom Query String

    This functionality should be in the core of WordPress. It’s crazy that it’s not possible to have a different number of posts on the front page (where they are displayed in full) compared to archive pages (where only excepts are shown). I’ll look at submitting it to Trac as an enhancement request.

    Thanks MichaelH!

    I sure agree with that jrawle ! =/

    About deactivating plugins it didn’t do it for me 🙁 deactivated all plugins, including Cqs and activating it again but no success. Also readded all the tables. I just don’t understand how the plugin still work for you jrawle but not for me. You haven’t changed any code have you? or have any other magic plugin or php code that makes cqs work?:)

    This is so anoying, seems as such a simple thing to do !
    Really hope they will add this feature in coming versions of wp.

    What version of CQS are you using? Make sure you’re using the 2.7 code.

    What version of WordPress did you upgrade from? I upgraded from 2.0.9 (I think). How did you carry out the upgrade process?

    I don’t think I have any other plugins that would affect this one.

    What is the link to your blog?

    While I can’t, off the top of my head, think of common plugins that might interfere with CQS, I *can* say I’ve seen plenty of themes that hardcode post counts and such.

    So, just for grins “agony”: Have you tried just using the Default theme to see if CQS works there?

    Oh yeah – and for the “This should be in core” folks: Have you been to http://wordpress.org/extend/ideas/ and suggested it?

    Handysolo: You were right, it was in the theme code. Thanks alot! all working now 😀 For some strange reason when i reinstalled from scratch, the theme i’m using (nishita) now had the “nr of post”-setting in archive php file. That setting must have been “overlooked” in previous wp version, since i cannot remember myself changing such a setting at all before. I also feel kind of stupid, since i noticed that cqs were working all the time, it was just the setting for the archive page that did’nt. Anyways, thank you all for the replyes! =) (btw, i’m still gonna suggest a nr of post setting for the wp core).

    Jrawle: If youre still interested taking a look the blog is at http://www.staeke.com =)

    Again, thanks all.

    Awesome – thanks for the followup!

    hi, everyone

    I seem to be having the same problem on my blog – the thing is I don’t know how to modify the template archive.php in order to get it working – where is the “number of posts setting”?
    for categories is working, just at archives is the issue

    thank you

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘[Resolved] CQS no longer working :(’ is closed to new replies.