Support » Plugin: Wordfence Security - Firewall & Malware Scan » CPU usage went to 100%

  • Resolved coinweek

    (@coinweek)


    Have a dedicated server with Rackspace – 24 core 48 gb memory. Website is [redacted]

    Got a call that our site was super slow and went in and see that server was spiking to 300% load average. We were confirmed that Clouflare was caching most of the site and the majority of requests we are seeing on the server were POST requests going to admin-ajax.php.

    We use the Newspaper theme

    Started disabling plugins to see if anything changed and when we got to Wordfence, disableing it dropped the load down from 300% down to 12%. The amount of apache processes decreased from over 900 to 544.

    We have been using Wordfence for years, but starting with you major version changes with I think it was 7.0. I have also seen a number of other people that have has similar issues.

    We deactivated every plugin and the only one screwiing things up was wordfence. We just updated to 7.05 . Whatever you guys have done in the last several updates have made your plugin useless to us.

    Spent 4 hours debuging and working with Rackspace and we are 100% sure it is a conflict in Wordfence that is the problem

    • This topic was modified 1 year, 11 months ago by Steve Stern.

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • We have the same issue. Cant even update any plugins unless wordfence is deactivated first, otherwise we get a time out error: ‘...webserver times out before responding. The likely cause is an overloaded background task, database or application, stressing the resources on your webserver.screenshot

    Contacted the host, they ran some checks and told us wordfence was responsible. There is also a cURL error 28 : operation timed out under php connectivity in wordfence.

    Hi @coinweek
    Could you please try a clean reinstall of the plugin? you can do that by checking “Delete Wordfence tables and data on deactivation” option under (Dashboard > Global Options > General Wordfence Options). Then deactivate and delete the plugin from WordPress Dashboard and re-install it again.

    Let me know how it goes,
    Thanks.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘CPU usage went to 100%’ is closed to new replies.