Support » Plugin: Mailchimp for WooCommerce » CPU sharp rise – from plugin

  • Resolved wood1e

    (@wood1e)


    Hi,

    My server company has just notified me that my CPU usage has risen sharply.

    They are saying the IP at the top of the list was our own server, because of MailChimp requests.

    xx.xxx.xxx.xxx – – [20/Jun/2019:23:47:27 +0100] “GET /wp-json/mailchimp-for-woocommerce/v1/queue/work HTTP/1.0” 200 30 “https://www.ourwebsite.co.uk/wp-json/mailchimp-for-woocommerce/v1/queue/work” “WordPress/5.1.1; https://www.ourwebsite.co.uk”
    xx.xxx.xxx.xxx – – [20/Jun/2019:23:48:39 +0100] “GET /wp-json/mailchimp-for-woocommerce/v1/queue/work HTTP/1.0” 200 30 “https://www.ourwebsite.co.uk/wp-json/mailchimp-for-woocommerce/v1/queue/work” “WordPress/5.1.1; https://www.ourwebsite.co.uk”
    xx.xxx.xxx.xxx – – [20/Jun/2019:23:49:18 +0100] “GET /wp-json/mailchimp-for-woocommerce/v1/queue/work HTTP/1.0” 200 30 “https://www.ourwebsite.co.uk/wp-json/mailchimp-for-woocommerce/v1/queue/work” “WordPress/5.1.1; https://www.ourwebsite.co.uk”
    xx.xxx.xxx.xxx – – [20/Jun/2019:23:50:06 +0100] “GET /wp-json/mailchimp-for-woocommerce/v1/queue/work HTTP/1.0” 200 30 “https://www.ourwebsite.co.uk/wp-json/mailchimp-for-woocommerce/v1/queue/work” “WordPress/5.1.1; https://www.ourwebsite.co.uk”

    Any ideas? Does this some times happen? As long as we are aware 🙂

Viewing 1 replies (of 1 total)
  • Plugin Author ryanhungate

    (@ryanhungate)

    @wood1e thanks for reaching out on this issue. We’ve heard from a few folks that this has happened, although we’ve never been able to replicate this in all of our hosting environments that we’ve tested with. We’ve even gone as far as getting the cheapest plans available with minimal resource allocation.

    That being said, we do want to try and address this for you, and there might be a super simple tweak that would do the job for your use case. We would only recommend doing this if your site does not have tons of shopping traffic, because it will slow down submissions to Mailchimp – but this might work so let’s give this a try:

    Put this constant in your wp-config.php file so that we disable the ‘long polling queue’ which should just do 1 job at a time and close out.

    define('MAILCHIMP_DISABLE_QUEUE', true);

    Can you please add this configuration and let it run for a bit and then report back?

    Thanks!

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.